Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I do love Xen as a product, but sometimes, I really hate it. I'm having some networking issues with one of my Xen clients sitting on a Debian 6 machine VM (so Xen is running inside a Debian 6 virtual machine). As always, the issue is bridging. Here are the commands I've ran so far to set it up. Believe me, I've rerun them again and again trying to see what the problem was.

xen-create-image --hostname=CN01061 --dir=/opt/xen --force \
--size=10gb --image=full --swap=2gb --memory=1gb --dhcp \
--dist=squeeze --arch=i386 \
--mirror=ftp://ftp.us.debian.org/debian/ \
--passwd --install-method=debootstrap


##### This is my network script
cat >> /etc/xen/xend-config.sxp << 'EOF'
(network-script network-bridge-wrapper)
EOF


##### This is the script itself
cat > /etc/xen/scripts/network-bridge-wrapper << 'EOF'
#!/bin/sh
/etc/xen/scripts/network-bridge "$@" netdev=eth0
/usr/sbin/brctl addbr intercomm0
/sbin/ifconfig intercomm0 192.168.198.1
EOF


##### Make it executable
chmod 0755 /etc/xen/scripts/network-bridge-wrapper


##### Edit /etc/default/xendomains

#XENDOMAINS_RESTORE=true <<-- the default value
XENDOMAINS_RESTORE=false # <<-- my value

#XENDOMAINS_SAVE=/var/lib/xen/save <<-- the default value
XENDOMAINS_SAVE=""                 # <<-- my value


##### Add intercomm0 interface to CN01061 (DomU client)
cat >> /etc/network/interfaces << 'EOF'
# intercomm0 interface
auto eth1
iface eth1 inet static
address 192.168.198.2
netmask 255.255.255.0
EOF

##### Finally, the config file /etc/xen/CN01061.cfg
dhcp = 'dhcp'
vif = [ 'bridge=eth0','bridge=intercomm0' ]

So, to summarize what's going on, the DomU client (CN01061) receives an IP via DHCP on its eth0 interface just fine, and has a static address on its eth1 interface (192.168.198.2) for communication between itself and Dom0. Dom0 has bridging setup between its eth0 interface and its intercomm0 interface (defined in /etc/xen/CN01061.cfg)

The bridge is configured correctly I believe:

root@dom0:~# brctl show
bridge name     bridge id               STP enabled     interfaces
eth0            8000.080027eeef71       no              peth0
                                                        vif1.0
intercomm0              8000.feffffffffff       no              vif1.1

The reason I'm smashing my head against the wall is because even though the DomU client receives an IP via DHCP, it's not reachable via SSH or ping from any other computer on the network. The DomU itself can't reach anywhere outside either; it can't even ping the gateway.

Any ideas? xen-hypervisor is 4.0.1-4, xen-tools is 4.2-1, and xen-utils is 4.0.1-4.

share|improve this question
    
Can you try running tcpdump on the Xen host bridge interface: tcpdump -i eth0 while pinging the gateway to see if the packets escape the guest or not? Have you checked the MAC address generated for the guest is unique? –  Paul Mar 25 '12 at 8:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.