Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to connect to WLAN with notebook. The notebook works fine with other WLANs.

It can authenticate, signal is "very good" but it says "can't access internet".

(On Windows it's small yellow exclamation mark on the signal).

With other computer exactly in the same location, with the same settings, it's possible to connect. Both are configurated to get IP dynamically.

One difference is that the other computer is using "Ralink wireless" instead normal windows client to connect. But does this make a difference? the settings are the same.

What could be the reason?

share|improve this question

migrated from stackoverflow.com Mar 25 '12 at 12:01

This question came from our site for professional and enthusiast programmers.

3 Answers 3

Because there are some instances where the wireless driver that is currently installed into your computer is not supported or even it is not compatible with the wireless that it trying to connect with.

share|improve this answer
up vote 0 down vote accepted

I'm in a hurry and just tried giving my computer static IP and it works. I guess the problem is somewhere retrieving dynamic IP. Why the other works - don't know, maybe there's something cached or a table with MAC address IP (...?), no idea. It works now. I'm not going to stay long in this place and don't have time to make a diagnose now, although it would be interesting.

share|improve this answer
    
You might have another computer on the network that has the same IP, try pinging the IP you received when you were on DHCP, that might give you a clue. Remember that unless you limit the DHCP range, mixing static/dynamic IPs can lead to a real mess, since the DHCP server won't think twice about handing out an IP that's configured as a static IP on another machine. –  MaddHacker Jul 4 '12 at 14:45

You have to diagnose to understand what's the source of the problem.
1. just try tracert -d -w 400 8.8.8.8 and show us the result
2. show us the routing table: route print
3. show us the ip configuration: ipconfig /all

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.