Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been running a web site for the past year on Windows Home Server 2008 R2. After the March 2012 system updates, the site is no longer accessible to clients. They see this error: website is online but isn't accepting connections.

Ping tests to the FQDN of the server are successful and NSLOOKUP returns the correct result. The Internet connection tests out good from the server. I have not changed my internet connection (Comcast Business Internet) or my router configuration (I forward incoming requests from the outside to port 80 of the local IP address of the server).

I have tried:

  • Disabling the Windows Firewall.

  • Rebuilding the OS and configuration.

I still have the problem. How can I resolve this?

share|improve this question
    
Hi, Michael. Unfortunately questions about home-hosted server is off-topic for ServerFault so this question will either be closed or migrated to a more suited site shortly. Please checkout the FAQ for the site you're posting on. What does canyouseeme.org say? –  tombull89 Mar 25 '12 at 13:42
add comment

migrated from serverfault.com Mar 25 '12 at 14:09

This question came from our site for professional system and network administrators.

2 Answers

up vote 1 down vote accepted

OK, once again this proved to be a hardware issue. And once again the erring network adapter was a Marvell device (built into a Shuttle motherboard).

Because this computer ran successfully for a year, only failing after the March updates from Microsoft, I think we can presume that the problem is with the drivers. My previous problem did not work from the start, but this machine ran fine until this month. In all cases, I had the most up-to-date driver, and in the case of this recent incident, I rebuilt the operating system from scratch, using a new driver than the previous build had used. Both situations provide perfect outgoing network traffic but fail on incoming traffic. So, neither machine could be used for my IIS server.

I have now moved the drives to a different Shuttle, one using an Intel network adapter, and it works just fine. Incidentally, I originally acquired the Intel adapter for the machine about which I am currently complaining. But putting that into the empty PCI-e slot on the Shuttle turned off the video on the Shuttle! No change in BIOS configuration properties made any difference.

share|improve this answer
add comment

One of IIS's services isn't running or the website is disabled in IIS Manager.

Check specifically for "IIS Admin" and "World Wide Web Publishing" services.

share|improve this answer
    
Sounds good, but the WWW Publishing service was running fine (I tried changing underlying account-from Local System- but no effect). I see no service related to IIS, itself. The Manager appliation runs fine. –  Michael Broschat Mar 25 '12 at 14:59
    
I just checked a different machine, and that has "IIS Admin Service." Will now investigate to see why my intended IIS machine does not! –  Michael Broschat Mar 25 '12 at 15:11
    
That was interesting. Turns out, "IIS Admin Service" is not used with IIS7+. Apparently, is an artifact from IIS6. –  Michael Broschat Mar 25 '12 at 15:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.