Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to completely reformat my internal hard-drive on an intel macbook. I'm having troubles. This is what happens in diskutil:

  1. Erase the drive selecting Max OS extended Journaled (HFS+ Journaled). Two partitions appear on the left tab. "disk0" (HFS+) and "Untitled" (HFS+ Journaled). "diskutil info" shows there are six disks (/dev/disk{0-5}. Three of them are nambed "untitled" and are small. /dev/disk1 is an apple partition scheme.
  2. Trying to install OSX with the CD (pushing continue), there are no disks to choose.
  3. Going back into DiskUtility, only the "Untitled" partition shows up under the main hard-drive. The disk and the partition appear to be "OK" according to DU (Disk Utility). I try various things: repartitioning, erasing the disk, deleting the partition and then repartitioning, change the name of the partition etc ... but I can neither mount the partition nor see it in the install screen. Disk Utility thinks the volume is "OK" when I verify it.

I previously had an ubuntu/OSX dual boot installed with refit. I'm not sure if that is relevant. I would think diskutil should be able to reformat a hard drive regardless of what was on it before.

I've also tried numerous things with diskutil and fdisk but with no luck. My next step is to try gparted.

I was running OSX on this prior to the reformat so I think the drive is fine physically.

Also, I've never intentionally used any encription on any of the partitions (maybe refit boot is encripted by default) so I don't think that is causing problems.

share|improve this question
up vote 2 down vote accepted

I believe what is happening is that the drive was partitioned with some other software, the ubuntu/OSX dual boot loader probably is confusing the situation...

Now this will be a completely destructive wipe of the drive...

  1. Go into disk utility
  2. Highlight the drive (not partition) that you want to wipe... (Down at the status bar, it should the Type (eg. Logical Volume Group), and Disk Status (Online / Offline). If that's not showing, then you have chosen the partition.
  3. Click On Partition
  4. Change Partition Layout to be 1 Partition
  5. Click On Options, change it to be GUID Partition Table.
  6. Apply the changes

Very often if a format / partition fails, it is due to the Partition Table being set to something other than GUID.

share|improve this answer
+1 This is a good workaround to the problem without having to resort to a Live CD. – user3463 Mar 30 '12 at 16:46
Thanks! This seems to have worked. I was sure I did all of this but I must have missed a combination. I think I probably didn't select the disk and selected the partition instead. – mathtick Apr 19 '12 at 2:13
Ah, that makes sense! Glad it got sorted! – user3463 Apr 19 '12 at 22:41

Use gparted and erase every single partition on the drive. Then boot off the OS X DVD and create a new HFS+ Journaled partition using Disk Utility.

share|improve this answer
Trying this ... am now having problems making a mac bootable usb. Am trying… and but with no lock so far. Will report back on this once I have it working. – mathtick Mar 28 '12 at 19:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .