Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A friend's machine recently died. At first I thought it would be the power supply but now it appears the (green) light on the front of the machine is lit and the motherboard light is also on. When an attempt is made to power on the machine there is no feedback, such as a couple of beeps. I now believe it's more likely to be the motherboard than the power supply. Based on these symptoms, what's your diagnosis? I can temporarily replace the psu with one of my own if there is any ambiguity in the likely cause of the problem to ensure whether the psu is to blame.

EDIT: I connected the motherboard plug from my machine to the machine in question. The difference this time round booting it is, is the fan turns on (and the fan on my machine..). There's no output to the monitor but I guess this could be due to my machine being only 350watt and the other 400watt. There is a four pin plug connected on the other motherboard. Connecting my plug to it turns the machine unresponsive (as opposed to the fan turning on when only my mobo connector is connected to it).

So, guessing it is prob the PSU...?

share|improve this question
    
What is the make and model of the machine? –  erichui Sep 13 '09 at 16:35
    
Generic gray box, I'm afraid –  Opflash Sep 13 '09 at 17:18

6 Answers 6

up vote 1 down vote accepted

Change the PSU if you can - if you have spare one, perfect.

I had exactly the same problem and it turned out to be a bad PSU. PSU's don't always just completely die. Symptoms on my own computer began with random restarts. Then the computer would sometimes get stuck during boot and eventually it failed to switch on at all. The LED on the motherboard was still on so I was stumped on what it was. I swapped the PSU out (on a hunch) and everything has been fine since (6 months later).

If you're swapping the PSU, make sure it is powerful enough to cope with whatever components you have in the computer. You can get a pretty good idea of what you need with this tool here.

share|improve this answer
    
When I swap the motherboard connector with mine the fan does turn on. Would this confirm the PSU is the cause? –  Opflash Sep 13 '09 at 17:04

Look for a physical problem first.

  • Check that everything is properly seated in it's slot (memory, graphics card, etc.)

  • Check that all power connections are solid.

  • Check that the disk cables are solid.

  • If the motherboard has onboard graphics remove the graphics card and use that instead.

share|improve this answer

It's probably the motherboard, from the sound of it. If the light on the motherboard is on it's most certainly not a problem with the PSU.

share|improve this answer

Actually the "couple of beeps" are important. Well, the count of them.

Some (most?) motherboards report low-level issues with beeps, as there is nothing else they can use to warn the user something is wrong (some have LEDs too). Too bad actually that the recent computer cases do not ship anymore with a speaker, or that the motherboard do not come with an on-board beeper.

Refer to the manual of the motherboard, they should indicate the possible cause of the issue for each number of beeps.

This type of diagnostic card is actually great to identify boot issues, as it reports with numbers the step the BIOS goes through when checking the hardware. And it has a speaker in case the case/MB doesn't have one. Helped me once to troubleshoot a computer not booting, it identified an issue with the USB controller.

share|improve this answer
1  
He said there's no beeps. –  alex Sep 13 '09 at 12:28
    
I thought I read there were beeps... Question edited? Or my English is really lacking? Or I really shouldn't come to SU when I have a party the night before ... –  Snark Sep 13 '09 at 12:57
    
But the part about the diagnostic card is still relevant! As is the one about MB and cases not having a beeper anymore! ;-) –  Snark Sep 13 '09 at 12:58
    
Here's the quote you're interested in: "When an attempt is made to power on the machine there is no feedback, such as a couple of beeps". From what I understand, nothing happens, not even a beep. –  alex Sep 13 '09 at 13:18
  • ChrisF's points are quite useful.
  • Besides that have you also confirmed with your friend that the default PC Speaker is wired?
    If its not wired, you may be missing the beeps being discussed by Snark.
  • Is there a harddisk light (usually orange)?
    If so, does it flicker when the green light goes on?
  • And, what is the state of the display?
    Does it show the BIOS splash screen or any sigh of life?
    It could also be a graphics path problem
    (with the harddisk trying to boot but nothing reaching the display).

btw: the beeps (if you can get them) are certainly important.
Not just the count, but also the beep duration and your BIOS version.
But, I am guessing you know that.

share|improve this answer

You may want to try and resetting the CMOS settings (with the appropriate jumpers on the motherboard. The symptoms you describe sound similar to a problem with the Dell Dimension 5150

Alas, for the 5150, it only provides a temporary fix.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.