Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm a Linux Mint (Lisa) and Tor Bundle user trying to use wget over Tor. After following the directions I found here, all I get when running wget is an output file saying, "514 Authentication required."

Here's what I did: I downloaded the latest version of Tor Bundle (Version 2.2.35-9) for Linux and extracted it. I ran ./start-tor-browser. Then in Vidalia I went into Setting -> Advanced, and uncheck "Configure ControlPort automatically." (Later I also tried changing "Authentication" to "None" but this still didn't work.) The IP address is set to localhost and the port is 9051.

From the terminal I said:

export http_proxy=""
wget -proxy=on

This gave me an output file saying, "514 Authentication required" instead of Any ideas?

share|improve this question
i've read that both TOR and Vidalia have configuration files, look for the words user or password there and see if it's not as you'd think like maybe there's some username or password there. – barlop Mar 26 '12 at 4:27

on Ubuntu or Debain, install package "torsocks"

sudo apt-get install torsocks

After that, use wget like this:

torsocks wget http://foo.onion/
share|improve this answer
doesn't work for me. 05:19:02 libtorsocks(22594): SOCKS server refused connection tor running on 9050 port, and it seems to be this beast does it on – holms Sep 25 '14 at 2:21

Tor standalone only includes a SOCKS proxy for connecting to the Tor network, and the Tor browser bundle doesn't add any additional proxies.

The usual method of dealing with programs that require an HTTP proxy is to install one of your own, such as Privoxy or Polipo, then chain that proxy to Tor. For instance, in Privoxy's configuration, you would specify:

forward-socks5  / .

Privoxy then listens on port 8118 and you configure your HTTP proxy setting to http://localhost:8118.

Unfortunately it appears that Linux Mint doesn't carry either of these packages in its repositories. You might consider switching distributions, or compiling one yourself.

share|improve this answer
Step by step instructions here. – Skippy le Grand Gourou Nov 4 '14 at 10:14

proxychains also does the job, with the following configuration

socks5 9150

$proxychains curl ProxyChains-3.1 ( |DNS-request| |S-chain|-<>-<><>-<><>-OK |DNS-response| is |S-chain|-<>-<><>-<><>-OK

share|improve this answer

Use Torify, which is a simple wrapper for torsocks and Tor, for example:

$ torify curl
$ torify wget -qO- -U curl

Before using, make sure your Tor server is up and running.

See also: How to anonymize the programs from the terminal? at Tor SE

share|improve this answer
This is probably the easiest solution for most people. – A.Danischewski Jun 22 '15 at 22:17

Maybe is checking X-Forwarded-For header and trigger an error.

I recommend you to test another one (this is my own, so I know there's no detections of any kind, just your public address) :

Edit: I think you should remove -proxy switch while it's not in man wget. IIRC, wget can detect the proxy itself. :

wget -q -O -
share|improve this answer
I have the same problem with But nice thinking though, it was a good idea to test that. – Asher Walther Mar 26 '12 at 1:33
See my edited post above – Gilles Quenot Mar 26 '12 at 1:42
could drop the -q too it looka from the man page thta -q is about supressing output. What is -0 ? – barlop Mar 27 '12 at 19:45
-q simply hides the progress meter – Gilles Quenot Mar 27 '12 at 21:34
you haven't answered the question =/ – holms May 5 '12 at 2:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.