Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today, I tried to install packages through apt-get, but I encountered a lot of 404 errors. My sources.list was fully working last Friday (no changes to my knowledge), now I get:

W: Failed to fetch  404 Not Found [IP: 80]

W: Failed to fetch  404 Not Found [IP: 80]

W: Failed to fetch  404 Not Found [IP: 80]

W: Failed to fetch  404 Not Found [IP: 80]

When I browse for example there seems to be no lenny directory. What's the issue?

share|improve this question
Ok, it seems that lenny is moved to archieve. No suprise as it's passed already EOF: – Fdr Mar 26 '12 at 7:42
Noticed the same just lately a and decided to move on. Will take me a night or so, but still better this way. The machine should have been better maintained in the first place :) – 0xC0000022L May 10 '12 at 13:35
up vote 68 down vote accepted


  • Lenny is EOLed
  • lenny security updates have been terminated on February 6th
  • lenny backports have been dicontinued on March 25th
  • lenny volatile has been discontinued with the release of its successor "squeeze"

the repositories have been moved to - you may wish to update your repositories to match this:

deb lenny main non-free contrib
deb-src lenny main non-free contrib
# Volatile:
deb lenny/volatile main contrib non-free
deb-src lenny/volatile main contrib non-free
# Backports:
deb lenny-backports main contrib non-free
# Previously announced security updates:
deb lenny/updates main
share|improve this answer
You saved my life and sanity with that answer. Thanks a lot! – Bartek Banachewicz Jan 6 '13 at 11:42
i've got W: GPG error: lenny/volatile Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY DFD993306D849617 – holms Feb 1 '13 at 6:29

I think you want to

gpg  --keyserver  --recv-keys DFD993306D849617

to avoid the "NO_PUBKEY" error.

share|improve this answer

The other answers didn't work for me - this worked:

mv /etc/apt/sources.list /etc/apt/sources.list.PREARCHIVE

From, make new /etc/apt/sources.list with

deb lenny main non-free contrib
deb lenny-backports main
deb lenny-backports-sloppy main


gpg  --keyserver  --recv-keys DFD993306D849617
apt-get update 
share|improve this answer
gpg needs some funny port number to request keys. How annoying. Why don't the use port 80. – Kaz Oct 28 '13 at 19:57

For people who like me are searching for a place to download individual packages for the Debian 5 Lenny the best option as of now is

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .