Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A much-needed Windows Update broke a Vista laptop that was running fine until then: After booting up, Windows displays "Please wait..." but it never goes anywhere. I waited for a couple of hours, there is a bit of disk activity, but it didn't work out in the end.

I booted with the Vista DVD, chose "Repair your computer" which said that there was nothing wrong :-/

Next, I booted it up with a Linux USB keydrive, and ran Gparted 0.8.1 (which includes ntfsresize v2011.4.12AR.4 libntfs-3g) which displays a bunch of warnings for the NTFS partition where the Vista system is located such as:

ntfs_mst_post_read_fixup: magic: 0x00000000 size: 1024 usa_ofs: 0 usa_count: 65535: Invalid argument Record 16 has no FILE magic (0x0)

Next, I ran ntfsfix /dev/sda2, which said:

Mounting volume... OK Processing of $MFT and $MFTMirr completed successfully. NTFS volume version is 3.1. NTFS partition /dev/sda2 was processed successfully.

Next, I rebooted Vista, which did a CHKDSK, before rebooting. But I'm still getting nowhere with "Please wait..."

Before I copy the user's data to another host and reinstall Vista from a DVD, does someone know what I could try?

Thank you.


Edit: In case someone else has the same issue...

After the BIOS, hit F8 and choose "Repair your computer", followed by "Toshiba HDD Recovery".

In addition to a 1,5GB partition labelled "WinRE", the hard disk contains a second partition labeled "Data" from which the application will fetch a system image and reinstall it in the "Vista" partition. Make sure you copy your data out of the system partition before doing this.

share|improve this question
    
What makes you think that the filesystem is suddenly broken? Can you boot into safe mode? –  ZippyV Mar 26 '12 at 12:08
    
Because I tried this, along with "Last good known configuration", to no avail. –  OverTheRainbow Mar 26 '12 at 14:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.