Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A certain xlsx file I work on refreshes (recalcc to cells) only when I save in Office 2010.
How come? How can I change it?

share|improve this question
1  
go to formulas and on the right there are calculation options, make sure it's automatic. – Raystafarian Mar 26 '12 at 14:12
    
@Raystafarian: prefer your solution over the accepted answer. Thanks for this! – Terry Jul 7 '15 at 12:35
up vote 5 down vote accepted

Excel will refresh when you press F9

Alternatively you could have a macro running that refreshed on a given time.

e.g.

Sub turnoff()
'Turn Off calculation and start call ontime routine
Application.Calculation = xlCalculationManual
Call DoTimer
End Sub

Sub DoTimer()
'Call the sheet calculation macro every one second
Application.OnTime Now + TimeValue("00:00:01"), "Rep"

End Sub

Sub Rep() ' calculate the sheet and repeat the ontime process
Sheet1.Calculate
Call DoTimer
End Sub

Source: Here

EDIT:

You can also check in Options - Formulas - Calculation Options to ensure that automatic calculations is turned on.
enter image description here

share|improve this answer
    
F9 indeed works, however in all other workbooks each time I change a cell all the dependent cells update automatically, that is the default behavior of Excel. Only this file acts weird. Do you know how I can reactivate the auto-refresh? – Jonathan Mar 26 '12 at 14:07
    
Does this question help: superuser.com/questions/249758/… – Joe Taylor Mar 26 '12 at 14:16
2  
Go into Options - Formulas - Calculation Options. (Top left) That's where it is set. – Joe Taylor Mar 26 '12 at 14:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .