Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been having problems with windows 7 waking from sleep after one minute or so on my laptop. I also have ArchLinux installed on this computer. A while back I tried a registry tweak to get windows to use UTC so it would play nice with Linux. The registry tweak didn't seem to work and my windows clock was always wrong. Today I deleted the registry entry that I added, and the problem with sleeping seemed to go away.

Can anyone make sense of this?
Edit: I'm specifically wondering about the sleep problem, not so much about the clock.

The registry entry I added was: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation] "RealTimeIsUniversal"=dword:00000001

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Ok. UTS is Universal Time Coordinated, or the same as Greenwich Mean time. Keep that in mind.

EST or Eastern Standard Time, which is my time zone, is -5:00 from GMT... or UTC. So, if the only clock I could see with my eyes was set to GMT, I would have to subtract 5 hours from it to know what time it was for me. Still with me?

Now, Linux and OSX see the BIOS clock of the computer they are installed on as UTC. Same thing as having the clock in the living room set to GMT. Linux and OSX maintain a conversion setting that the user sets at one point (stating what time zone they are in) so that they display the correct local time to the user.

Windows is different. Windows sees the BIOS computer clock as the local time, without having to convert it.

This is why your Windows clock was always wrong. After the Registry tweak, you still missed telling Windows to convert the clock to your correct local time with the right time zone setting. If you want Linux and Windows to play nice at this point, without the registry tweak AND with your Windows sleep function working properly like it is... you will have to change the time zone setting in Linux to assume GMT or UTC +-0.

share|improve this answer
    
Thanks for the reply. This is definitely helpful. I was actually wondering more about the sleep problem (reflected in my edit above) but I do appreciate the quick response. –  xthrd Mar 26 '12 at 18:11
    
What threw me off the track of attempting to fix the sleep issue, was this line "Today I deleted the registry entry that I added, and the problem with sleeping seemed to go away." Microsoft says it could be Media Center's fault... support.microsoft.com/kb/979878 but THIS article points out not only could it be your network card, but the command to find out what woke it up. powercfg -lastwake cravingtech.com/… –  Bon Gart Mar 27 '12 at 15:39
    
I actually tried the lastwake command but it never gave me any clues: Wake History Count - 1 Wake History [0] Wake Source Count - 0 The system log was also devoid of any helpful information, as was the powercfg energy diagnostic. But it's working fine now so I guess I just chalk it up to luck. –  xthrd Mar 27 '12 at 21:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.