Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have done all the steps for enabling php on the Mac:

  • edited httpd.conf to uncomment loadmodule for php
  • verified that php.conf has the right information
  • have web sharing enabled

But the apache server still doesn't open my php file as a web page. What else must I do to open php pages?

share|improve this question
up vote 1 down vote accepted

Editing /etc/apache2/httpd.conf, restarting Apache and making sure the file you want to view ends with .php is all you need to do.

share|improve this answer
    
I think restarting Apache is the key here. +1 for you. – user3463 Mar 27 '12 at 5:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .