Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

ClearType is a great technology. It takes us out the age of the pixel by smoothing fonts. Then you rotate your monitor and everything is messed up. Or you buy an exotic, non-RGB-pixels, monitor, to the same effect. Or you just-don't-like-it.

Then you try to disable it because it makes you frown and you can't stand the headaches. You find the option in the control panel but it does not work. You're in a world of pain.

You want to disable ClearType everywhere. How?

share|improve this question

1 Answer 1

Here is a collection of the 1001 ways to disable Unholy Microsoft ClearType in Windows 7, which I found scattered over the Internet. Some items might work with other versions of windows.

(Menu and buttons names may be incorrect because my version of windows is Not In English).

  • Global settings
    • Open the Control Panel
    • type "ClearType" in the search bar
    • Open the link
    • Uncheck the "Enable Cleartype" checkbox
    • Press next-next-next-Finish, ignoring the unexpected and useless configuration options.

You may notice that something has changed, but everything is as blurry as ever. The start menu has a big fat font, like everything is bold.

  • Global settings (again)
    • Open the Control Panel
    • Find the performance options ("Adjust the appearance and performance of Windows")
    • Disable "Smooth edges of screen fonts"

I suspect that the next one is only another way to do what we just did above, but here we go:

  • Font Smoothing in the registry
    • In regedit, open [HKEY_CURRENT_USER\Control Panel\Desktop]
    • Change FontSmoothing and FontSmoothingType to 0 (zero)

Not everything is crisp, that's because your default system font is antialiased, probably Segoe UI. Let's change it.

  • Change the system font
    • Right-click the desktop
    • Select Personalize
    • At the bottom of the window, click "Window color"
    • Click "Open classic appearance properties for more color options"
    • Select each item in the "Item" combo box and, when the "Font" combo box is enabled, change the font
      • Some fonts don't have antialiasing, try some and keep the one you like. I like Tahoma
    • When you have changed all the fonts, click OK and wait for a long time.

At this point things should be getting better. Folder browsing is OK but Office and IE are not. Now begins the real work. We'll have to disable ClearType for each and every application that uses it.

  • Office

    • In regedit, open [HKEY_CURRENT_USER\Software\Microsoft\Office\Common]
    • There should be a key named RespectSystemFontSmooth. If there's not, create it as a DWORD
    • Set its value to 1
    • There is a "Common" folder in some subfolders of "Office", those with version number names, like "8.0", "11.0" and "14.0", edit or create the RespectSystemFontSmooth in the Common folder of these, too. Ex: [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common]
    • Same for [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Common]
    • And again, search for RespectSystemFontSmooth in the whole registry, there might be other occurrences.
  • IE

    • Open IE
    • Open the "Tools > Internet Options" menu
    • Go to Multimedia
    • There may or may not be a "Always use ClearType for HTML" option to disable, my version hasn't, but some forums point at it.
    • Note: In non-english versions of IE, there might be no reference to ClearType. For instance, in portuguese, the option is called "Habilitar codecs alternativos nos elementos de midia HTML5", which is quite deceitful. Anyway, it's the first item under "Multimedia".
    • If you can't find the option, open regedit and set [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\UseClearType] to "no"
  • Visual Studio

    • Open Tools > Options > Environment > Fonts and Colors
    • In the "Show settings for" combo box, select "Text editor"
    • In the "Font" combo box, select an unaliased font, like Lucida Console (for code, you most likely want a fixed-width font, which is why they are in bold in the list)

Not sure about this one, but it never hurts:

  • IE again
    • In regedit, open [HKEY_CURRENT_USER\Software\Microsoft\Advanced INF Setup\IE UserData NT\RegBackup\0.map]
    • Search for "UseClearType"
    • Edit the key and remove the UseClearType part
    • Search again for "UseClearType", for there might be other occurrences of the key.

Some other apps have their own settings, and I'm afraid some of them have hardcoded settings, which means you really can't possibly do anything about it. I'm still searching how to disable ClearType in...

  • Microsoft Lync
  • The Control Panel
  • Some system windows, like the clock or the menu-like bar between the address bar and the actual icons in the explorer window, the one that starts with "Organize"
  • Most title bars.

Please Edit this post to add any additional step towards salvation.

share|improve this answer
    
I'd like to disable Cleartype in MS Paint. Is this possible? –  Ambo100 Jun 17 '12 at 20:07
    
@Ambo100 Well after all this, it should be crisp already. –  Gabriel Jan 16 '13 at 16:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.