Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently purchased a Buffalo N600 wireless router which came with DD-WRT pre-installed. I want to take my old wireless router, a Linksys WRT54GL, also with DD-WRT pre-installed, and use it as a wireless bridge for my HTPC and Blu-Ray player in the other room. I other words, I'm trying to connect two WIRED networks via the wireless on the routers.

I followed exactly the instructions from DD-WRT's manual for 'Client Bridged', however I'm still not able to connect the two routers correctly when encryption is enabled (WPA2-Personal Mixed). However, I am able to connect the two routers when there is NO encryption.

I've checked, double checked, and triple checked that EVERYTHING is the same on BOTH routers:

Routers 1 & 2

Encryption: WPA2-Personal Mixed

Wireless Mode: G-Only

Wireless Channel: 6

Subnet Mask: 255.255.255.0

Subnet: 192.168.1.0/254

SSID: Krono$

Primary Router #1 (Buffalo N600)

IP Address: 192.168.1.1

Firewall: Enabled w/ defaults

DCHP: Enabled as DHCP Server

Secondary Router #2 (Linksys WRT54GL)

IP Address: 192.168.1.2

Firewall: Disabled as per DD-WRT instructions

I'm looking for any settings that I may have missed, or settings that may need to be changed in order for this work.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

There are a few things that may help the situation:

First off using the WPA-Personal Mixed may cause some problems. From DD-WRT's website:

Mixed mode allows device to try WPA2 first, and if that fails fall-back to WPA.

Since there's a fluctuation between the two modes, there may be communication errors between the two routers. I would suggest trying to use solely WPA2-Personal without the mixed.

Second, AFTER makings sure that the SSID and pass-phrase are the same for BOTH Routers, go to Status >> Wireless >> Site Survey (located at bottom of page) and look for you primary router's SSID. Select Join and you should receive a dialog box confirming the successful joining to that network. (Note: DD-WRT's website explicitly says NOT to do this, but I found that this does work)

After doing the above and checking to make sure that you can communicate between the two networks, you can actually change the Channel and Wireless Mode for both routers to Auto/Mixed (respectively) and it should still work. This brings the advantage of DD-WRT's looking for the best channel to operate on, in case other wireless routers are using the same channel nearby. Also this enables the Buffalo Router (or other Wireless N routers) to allow other clients to use Wireless N instead of being solely restricted to the Wireless-G that the Linksys router only supports.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.