Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Usually, when eMule is started, after some time, I find that the router is jammed, so the internet connection on that computer stopped working, or it seemed to be waiting for some port to be freed up before it can connect to a website. This sometimes affect even other PCs or Macs using the same router.

Is there a way to prevent eMule from hogging too much resource or ports? I see that there is under Options -> Connection "Max Sources/File" and a "Connection Limits - Maximum Connections". Right now I set them to really low numbers: the first to 120 and the second to 200, but what are good numbers to fill in there so that it can work well without jamming up the router or use up the network resource of the PC or Mac? Or could it be that the number of files that are "Waiting" is too high, and used up too much resource? (If so, can emule automatically limit the number to 10 or 20 to prevent using too much resource?)

(This happened before on Linksys router, Netgear router, and the AT&T U-verse router.)

share|improve this question
    
What I like to do is to have separate VM with both Torrents and ED2K. If I use VMWPlayer in bridged mode I can always restrict the bandwidth usage via VMWPlayer NIC properties. –  Darius Mar 26 '12 at 22:54
    
the bandwidth for upload and download can also be set in eMule's option... although I wonder if that helps, as eMule might not be downloading but just waiting for download in various queues and still use up the resource... –  the searcher Mar 26 '12 at 23:03

1 Answer 1

up vote 2 down vote accepted

Make sure the router has the latest firmware. Typically, the problem is that the router's NAT table gets full. Strcitly limiting the number of connections is about the only thing you can do, other than replacing the router. Limiting it to 40 should keep the router stable without significantly affecting your transfer rates.

share|improve this answer
    
if I use the "Wizard" in that Options dialog and choose the lowest level of DSL (1024 kbit/s down and 128 kbit/s up), then it will even set the first number to 500 and the second number to 400... so right now setting it to 120 and 200 are really low numbers... I do have 18 Mbps down speed, so I thought I should be able to have higher numbers, but just don't know what numbers to use so that it is not too high and not too low –  the searcher Mar 27 '12 at 0:44
    
Try 120 and 40. See if the router is stable. You might also want to post the make/model of your router. –  David Schwartz Mar 27 '12 at 0:44
    
is there a typical number for NAT slots for modern routers? The one I have is a 3800HGV-B (2Wire Gateway 2wire.com) from u-verse. The older one was Linksys WRT54G and an earlier one was Linksys BEFW11S4. –  the searcher Mar 27 '12 at 1:13
    
The 3800HGV-B should handle 200 connections total. There have been reports of its DNS system consuming large numbers of its own connection slots, so hard-coding your machines to use other DNS servers (rather than using the 3800HGV-B as a DNS proxy) may help. If it gets bad enough, you can switch the 3800HGV-B to bridge mode and use your own router than can run open source firmware. –  David Schwartz Mar 27 '12 at 1:23
    
how about setting the first number to 80 and the second number to 120? If 120, will it be about 60% of the max, so it shouldn't affect the normal operation of the router too much. Will the first number usually be smaller than the second number, as that number is per file? –  the searcher Mar 27 '12 at 2:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.