Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I boot my MBP, the menu bar doesn't appear. When I open Mail.app or Safari, the menu bar appears. I've searched for a bit, and nothing seems to talk about this. Is there a way to fix this?

UPDATE

From the Console logs:

3/29/12 7:05:10.037 AM com.apple.launchctl.Aqua: load: option requires an argument -- D
3/29/12 7:05:10.037 AM com.apple.launchctl.Aqua: usage: launchctl load [-wF] [-D <user|local|network|system|all>] paths...
3/29/12 7:05:10.100 AM com.apple.launchd.peruser.501: (com.apple.launchctl.Aqua[153]) Exited with code: 1
share|improve this question
    
Does the Dock open automatically when you start up? Does the menu bar appear when opening Finder? – user3463 Mar 27 '12 at 6:56
    
What happens when you type killall SystemUIServer (keep the caps) into Terminal? – CoffeeRain Mar 27 '12 at 14:03
    
@RandolphWest The dock does, yes. The menu bar does not appear when opening finder. @CoffeeRain I'll try killall SystemUIServer when I return home. But wouldn't a reboot solve that as well? I've rebooted several times. – Glen Solsberry Mar 27 '12 at 15:18
    
@CoffeeRain unfortunately, killall SystemUIServer didn't do a lot. – Glen Solsberry Mar 27 '12 at 23:47
    
There are some steps to follow on this thread: discussions.apple.com/thread/1064792?start=0&tstart=0. Start with a Repair Permissions, then remove any third-party plugins you may have recently installed. At least it comes back when you open certain programs, so you can see what's loaded. – user3463 Mar 28 '12 at 14:37

Copy all of your files to a new user account on your mac and delete your current user. I had this issue myself and this fixed it.

share|improve this answer

This is old, but I had the same problem.

I tried deleting systemuiserver.plist from ~/Library/Preferences and ~/Library/Preferences/ByHost and restarted the computer, but it didn’t work.

I then went into the “Desktop & Screen Saver” preferences, deselected and then reselected “Translucent menu bar.” When I rebooted, the menu bar appeared. I rebooted a few more times just to test it and it loaded every time.

share|improve this answer

try adding SystemUIServer as a login item? (should be in hd\system\lib\coreservices or something like that)

share|improve this answer
1  
What would that possibly achieve? – Andrew J. Brehm Mar 29 '12 at 11:23
1  
SystemUIServer only handles the icons on the right, AFAIK. – Daniel Beck Jul 15 '12 at 18:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .