Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a weird problem with the Excel. Every time I copy and paste only the text is copying and the format is not copying as shown in the below figure. There are no paste special options available while pasting. In the Below figure I have copied A1 cell with ctrl+c and pasted in A3 with Ctrl+v. Here only text is pasted the format was not

enter image description here

These are the following solutions I have tried but no luck 1. Repaired MS Office with LIVE CD. 2. Checked the format cells. 3. Tried by closing all instances of Excel.

Interestingly when i went to paste special options as shown in the below screenshot only Text and Unicode options were available.

enter image description here

Please HELP me how to solve this weird problem.

share|improve this question

migrated from stackoverflow.com Mar 27 '12 at 5:44

This question came from our site for professional and enthusiast programmers.

1  
Do you have any add-ins or anything like that? These could be causing this behaviour. Try opening Excel whilst holding down the Shift Key (to disable add-ins) to see if this makes any difference. –  creamyegg Mar 16 '12 at 11:17
    
Let me try. Intead I will uninstall add-ons –  Vikram Mar 16 '12 at 11:21
    
No Luck creamy. still the problem exists :-( –  Vikram Mar 16 '12 at 11:24
1  
If you're copying from one Excel window to another then they're open in separate instances. If you opened excel twice from the start menu short cut this will happen. Open one file, open the second via the open dialog and try it again. –  Jesse Mar 16 '12 at 17:30

6 Answers 6

up vote 3 down vote accepted

First, try to run in safe mode : Excel.exe /Safe (in the run command) if that works correctly there, that means that it's due to either an add-in or a workbook that is loaded at startup.

(File>Options > Addins - uncheck all Addins) Note which ones were selected. Close Excel and then reopen it

If that works, then one of the addins was the issue, just have to find which one by reenabling them one by one.

If this didn't work, then it's probably due to one file located in the startup directory of excel. (ie C:\Program Files\Microsoft Office\Office14\XLSTART for me)

Any file in there is loaded when you start Excel. Remove the files out of that folder and open Excel to see if the problem is gone.

if that works, add them back one at a time, closing and reopening Excel each time until you determine which file was corrupted.

share|improve this answer

I had the same issue and removing (or put it on 'disable') the add-on 'Skype Click to Call' from Skype in the IE-browser under Internet Options and the tab 'Programs' - 'Manage add-ons', it was solved. Seems that the new Skype version is adding this 'add-on'.

share|improve this answer

Simple solution : File>Options>Add Ins> Manage (its placed below right)> Choose Actions from multi option menu > Click GO > Check box - Enable additional actions in the right click menu.

share|improve this answer
    
Seems unrelated; I tried it and it affects only the context menu for me. Sorry if this in fact is the answer to the original question. –  Nickolay Oct 10 '12 at 14:04

The same happens to one of my user. Excel settings are all the same as what other users have but he just can't do the paste special as usual. Found out that it's the IE add-ons that caused the issue as whenever he clicks on a link to open in IE, the Paste Special will stop working right.

So to recap:

  • Disable Bing bar add-ons
  • Disable Sype's Click to call addon
share|improve this answer

I had the same problem. After reading these posts, I did one simple intervention that helped:

  • Went into Firefox prefs, disabled Skype Click To Call.

Presto: problem solved. Bizarre but true. Thanks to all above!

Same is also true for Chrome - right click on the Skype add-in and disable it.

share|improve this answer

Somewhat related problem: the "Paste options" dropdown might not appear at all when pasting, if the option to make that happen got disabled somehow.

The option is File -> Options -> Advanced -> "Cut, Copy, and Paste" section -> "Show Paste Options button when content is pasted". One time it got disabled, although I didn't turn it off explicitly.

share|improve this answer

protected by Community May 25 '12 at 18:20

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.