Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having issues with Lego Digital Designer.

I have a relatively new HP computer (less than 2 years old) running the latest up-to-date version of Windows 7 (64 bit). About a year ago I was using a 4.x version of LDD just fine. I could open, build, connect to the internet, etc. No problem. I haven't used it since and tried launching it today. A blank application window would appear with a splash screen image in the middle and then...nothing. It just hangs there.

So, I thought maybe I need to update LDD. I ran the uninstaller, got the more recent version, installed that and...same thing.

Googling the issue I see lots of posts going back a few years with all sorts of random problems (mostly about Vista). I tried many of the 'fixes' (running as admin, changing compatibility mode, etc.) but nothing seems to resolve the issue.

Anyone else having this issues and know of a fix? I'm guessing something Windows updated over the past year has broken whatever LDD needs to run.

share|improve this question

migrated from Mar 27 '12 at 8:17

This question came from our site for LEGO® and building block enthusiasts.

The relevant support page on the LEGO site is as unhelpful as it gets... "Windows Vista and 7 is (sic) supported!". Now, that may sound naive, but did you reinstall it from scratch form a fresh download? – Joubarc Mar 5 '12 at 11:05
@Joubarc yep. Did a complete uninstall and reinstalled with the latest download from the site. – DA. Mar 6 '12 at 18:09

Taking stab in the dark, have you updated your video drivers?

I ran into a problem this week with my laptop running Windows 8 Consumer Preview where the drivers that are available for the ATI chipset it uses do not have a good OpenGL implementation. In that case I did at least see the loading screen and an error warning of the OpenGL problem, but it does make me wonder if in your case there might be some other issue with your video drivers.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .