Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As title says.. How do I logon as Administrator using remote desktop..

I have a laptop and 3 Dekstop PC's all running windows 7 etc.. I can create accounts on my Desktops and connect to them via remote desktop.. But I cannot connect as the administrator..

The problem I have is that all my work, folders and programs are on the Administrator account as Im the only user. If I can only connect by setting up a new user I cant use any of my files, folders and programs..

When I say "connect to desktop" it asks for username & password.. My Administrator account doesnt have a password.. Although I have tried setting one on the desktop and using "Administrator" as the username and then my newly set password.. But I cannot log in.

Im confused!

What am I missing ?

share|improve this question
1  
From a security perspective this is easy - stop logging in as Administrator. Its just plain risky. Microsoft intentionally makes this hard. Move your data to a regular user account and use it. (Sorry to be preachy) –  uSlackr Mar 27 '12 at 12:50

2 Answers 2

up vote 2 down vote accepted

By default accounts without passwords are restricted from logging in via remote desktop (they are limited to console logins only). You can override this by following the steps below:

To configure the Remote Desktop host computer to accept user name with blank password, go to Control Panel -> Administrative Tools (Under System and Maintenance in Windows Vista) -> Local Security Policy. Alternatively, run GPEdit.msc (Group Policy Editor).

Then, expand Security Policies -> Local Securities -> Security Options (for user using Group Policy Editor or GPEdit.msc, expand Local Computer Policy -> Computer Configuration -> Windows Settings -> Security Settings -> Local Policies -> Security Options). Locate Accounts: Limit local account use of blank passwords to console logon only policy, and set its value to Disabled.

share|improve this answer
    
Great explanation.. many thanks. –  newy Mar 27 '12 at 16:38
    
@Martin, Since it's a quote, where's the link to the source? –  Pacerier Feb 27 at 23:45

Best practices aside for a moment (don't log in as admin) I would need some information. I assume these are all local accounts? If not, check the domain you are logging into. If it says logging onto [computer name] and you really want to use a domain admin account use: domain\user for the login id.

Also, what is the error message it gives you? (I would have just posted this in comments, but I can't yet).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.