Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to toggle fullscreen in iTerm2 by pressing "cmd+enter". Unfortunately it doesn't work when 'top of screen' style is selected in the profile settings (as shown in the attached png). When I press "cmd+enter", the 'view' tab in the menu flashes, but the window remains taking up half the screen instead of fullscreen.

Is it just not possible to switch between halfscreen and fullscreen?

iTerm profile settings

share|improve this question

2 Answers 2

I think this is a bug. I also am unable to go into full screen when switching the style to anything other than normal.

I also have a different version of iTerm than you from what I can tell. (Build 1.0.0.20130319)

iterm settings

share|improve this answer
    
I am seeing this behavior too on the same build you have (Build 1.0.0.20130319) –  TrinitronX Jun 6 '13 at 20:19
    
Looks like this is a known bug targeted for a future release. –  TrinitronX Jun 6 '13 at 20:45
    
It is fix in the current beta, and will be available in the future iterm3 (end 2015) iterm2.com/downloads.html –  AdrieanKhisbe Jul 14 at 10:03

Having 'Top of Screen' selected indeed breaks the 'Cmd + Enter' fullscreen capability, but I've noticed that having the Preferences > General: Use Lion-style Fullscreen windows option checked also does a trick on this functionality.

Once you uncheck this, you should be able to use any other style (except the 'Top of Screen' one), and benefit from a functional fullscreen feature ;)

Mac OS v10.10.3
iTerm2 v2.1.1

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.