Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use MinGW on windows 7. I have a .bashrc with some aliases in it. The file is in my home folder which is where MinGW starts me in, so it also believes that the folder is my home folder. It does not load the contents of the folder automatically. I have to run the bash command to get the aliases to work.

I have tried renaming it to .bash_profile. This only made things worse as it didn't load automatically and also didn't load when I ran bash manually.

How can I fix this problem?

share|improve this question
    
Sorry the path should have been: C:\MinGW\msys\1.0\home\Your_Username_Here\.profile – user125075 Mar 27 '12 at 18:15
up vote 31 down vote accepted

bash is probably getting started as a login shell, in which case it doesn't read .bashrc automatically. Instead, it reads .bash_profile. From the Bash manual:

So, typically, your `~/.bash_profile' contains the line

`if [ -f ~/.bashrc ]; then . ~/.bashrc; fi'

after (or before) any login-specific initializations.

So in summary, create a .bash_profile file in your homedir, and add the line quoted above.

If your bash is actually getting invoked as sh, then you'll need to use .profile instead of .bash_profile (see the "Invoked with name sh" section of the Bash manual link above).

share|improve this answer
    
Thanks for the idea, didn't work though. Like I said in the question, putting the alias commands in .bash_profile doesn't work at all, so it seems like that doesn't get read. – KurToMe Mar 27 '12 at 17:15
4  
This gave me the idea to do exactly what you said except to put it in the .profile file instead. For some reason that worked (maybe MinGW doesn't use Bash by default or something crazy). If you add this option to your answer I'll mark it as accepted. – KurToMe Mar 27 '12 at 17:17
1  
Ah, there was a typo in my question that I fixed, I was calling it .bash_rc in the question, but I meant .bash_profile. – KurToMe Mar 27 '12 at 17:41
    
somewhat more terse: [ -f ~/.bashrc ] && . ~/.bashrc – Rich Homolka Mar 27 '12 at 18:42
    
@KurToMe I edited to cover your situation. – jjlin Mar 27 '12 at 19:04

I am running Windows XP and had the same problem. I found HOWTO Create an MSYS Build Environment.

This is the important line:

To help identify the runtime build and the current working directory, the following can be added to the ~/.profile file.

In MinGW shell, I created .profile:

cd ~
touch .profile

I used Notepad++ to edit it as a Unix format text file named .profile and saved it in my home directory, C:\MinGW\msys\1.0\home\Your_Username_Here\.profile

Then I added my alias and saved:

alias n='nano -w'

Then I fired up the MinGW Shell shortcut from my start menu and hurray, it worked! nano with no text wrapping.

I hope this helps you.

share|improve this answer
    
What you're saying doesn't jive ... ~ means the users home directory ... then your stating c:\MinGW\msys\1.0\home ... that doesn't make any sense the tilde is a reference to the USERS home ... on windows that %userprofile% ... – Eddie B Oct 20 '12 at 5:09
    
@Bryan: +1 thanks, it works – legends2k Apr 22 '14 at 7:09

I did not find the .bash_profile to work for me (it wasn't being read), so I took the .profile approach and put within it:

exec bash

This replaces my current shell with a fresh start of bash, which read my .bashrc

I'm thinking that using a .profile suggests that sh is used at login, not bash.

share|improve this answer

For me for MINGW installed with GIT, worked: .bash_profile put in C:\Users\[user_name]

This is also the directory where ~ points to in shell (pwd).

Just like that :)

share|improve this answer

How To setup MSYS bash intialization files

In WIN OS, the way you point to the intialization files used by bash (i.e., profile, bash_profile, bashrc) is different compared to LINUX OS.

The difference between WIN and LINUX OS is their file system structure, which leads to difference in BASH file locations and file naming conventions.

How To setup MSYS bash initialization files (i.e., profile, bash_profile, bashrc)

1) In WINOS, open the 'etc' folder located here 'C:\msys\1.0\etc\'. Note. you should see a file 'profile' inside 'etc' folder.

2) Save a no-file-extension file (i.e., when you save set the save as type to '.all files') with the file name '.bash_profile' to 'C:\msys\1.0\home\USERNAME'. Note. there is dot as prefix for the file name (e.g. '.bash_profile') as you would expect in LINUX OS BASH setup

2) Save a no-file-extension file (i.e., when you save set the save as type to '.all files') with the file name '.bashrc' to 'C:\msys\1.0\home\USERNAME'. Note. there is dot as prefix for the file name (e.g. '.bash_profile') as you would expect in LINUX OS BASH setup

4) Open the 'profile' file in a text editor (sublime text x is good) Note. the file location of 'profile' is 'C:\msys\1.0\etc\'

Inside 'profile' file, scroll to line of text at the end of the file (i.e., scroll to the bottom) you should see a line a test indicating bash to change its current directory to HOME (In MSYS, HOME is as defined in 'profile' file)

CD $HOME

5) Before the line with text 'CD $HOME' copy the following code -- adding this script within 'profile' will tell MSYS bash to run the bash_profile #--------------------------------------------------------------------------- #modified BEGIN

# Note. -f is a flag in the file-test operator set of bash commands 
#       that test whether file exists  
echo '[i] INFO loading personal environment variables and startup   programs.... '
BASHRC="$HOME/.bash_profile"
if [ -f "$BASHRC" ]; then 
  source "$BASHRC"
fi

#modified END
#---------------------------------------------------------------------------

6) Open the 'bash_profile' file in a text editor (sublime text x is good) and the end of the file (at bottom of file)

7) Copy the following code at end of file -- adding this script within '.bash_profile' will tell BASH to run the '.bashrc'

#---------------------------------------------------------------------------
#modified BEGIN

# Note. -f is a flag in the file-test operator set of bash commands 
#       that test whether file exists  
BASHRC="$HOME/.bashrc"
if [ -f "$BASHRC" ]; then 
  source "$BASHRC"
fi

#modified END

#---------------------------------------------------------------------------

8) O.K. now lets write a small script inside '.bashrc' to see if 'profile' is calling 'bash_profile' and if 'bash_profile' is calling '.bashrc'.

8.1) Think of a command name you wish to create, lets use 't' to mean test

8.2) open bash terminal and type 't'. Bash should reply 't: command not found' -- if it does not say 't: command not found' then repeat 8.1 and 8.2 until your command name says 'command not found'. You do not want to alias a command name that is assigned to bash BAD!, so it must be 'command not found'

8.3) O.K. 't' gave me a 't: command not found' now lets write the script into '.bashrc'

8.4) in '.bashrc' write

# use double quotes or bash will not write it
alias t="echo passed test"

8.5) save file '.bashrc' in 'C:\msys\1.0\home\USERNAME'

9) almost there, now restart bash terminal, make sure to close any previously opened bash terminals

10) type in terminal 't' it should reply 'passed test' if not carefully check that code was correctly written. (start by checking quotes)

some notes 1) 'source filename' is the same as '. filename'

2) " " double quotes allow variables to be replaced by its contents single quotes do not

3) $HOME is /home/USERNAME same as ~ is /home/USERNAME

4) a function are always preferred over alias 1

for more detail see BASH reference

I am new to bash. So there is no guarantee I did this the best way.

Good Luck!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .