Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running windows 7 home basic (64bit) on a Acer 5742G laptop with Atheos wifi adapter in it. Yesterday, I hiberneted my computer as I always do and up untill then the wifi was working fine. When I booted my computer up again today I started having a strange problem: It detects my wifi but after connecting to it, it keeps on oscillating between states of no network access and no internet access. I can't connect to anything (the internet or my router). I tried to reset my internet protocol stack using this fixit file. I also tried to uninstall and reinstall my network driver. Neither helped.

I am using the same laptop's fedora installation right now and the wifi is working perfectly fine. Please help.

Edit To add additional details, I have Microsoft Security essentials as my antivirus software and I haven't messed with the firewall or the router configurations.

share|improve this question
Out of curiosity you didnt flip the wireless on/off switch did you? – KronoS Mar 27 '12 at 15:56
Yeah I did that too. I turned off then on again my router and my wifi adapter. – Rick_2047 Mar 27 '12 at 16:01
updating my wireless driver trashed some of my connections some days ago. Have you tried deleting the wireless connection profile and reconfigured it? – Baarn Mar 27 '12 at 16:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.