Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On our laptop (running Windows 7) the Wi-Fi connection drops intermittently.

Symptoms:

Connectivity is suddenly lost, and the "signal strenght" indicator in the tray shows zero strength and a yellow "star" symbol.

What happens then:

  • The problem does not resolve itself by just waiting.
  • If I click on the tray icon, the "Windows network diagnostics" wizard pops up and tells me that there is a networking problem (duh).
  • If I click on the "repair" button (not sure about the wording), the wizard works for a while, then reports that it has reset the network adapter. Then Wi-Fi works again.

While the above procedure has worked every time so far, it is very annoying. It takes 10-20s to repair the connection, and in the meantime downloads, video streams etc. may have been aborted.

Some more details:

  • The problem occurs without any apparent regularity, but usually a few minutes after powerup (though not every time). It happens frequently enough to be annoying.
  • It is unlikely to be a router problem - another laptop running at the same time usually has no Wi-Fi problems.

I am at a loss about what to try to troubleshoot this. Any ideas?

Computer: Acer Aspire 7739Z. Wi-Fi card: Atheros AR5B125

Edit

Some more details. The network is a simple home network:

  • Internet via ADSL from Deutsche Telekom (I'm in Germany)
  • ADSL modem/router/WiFi AP combo from Deutsche Telekom (Speedport W723V), using WPA2.
  • Only two computers connected, both laptops over WiFi. One shows the problems described, the other (an old Thinkpad running Linux) works fine, even while the other computer is having connection problems.
share|improve this question
    
What network related entries show in the Windows 7 event log (application and system)? –  Jeremy W Apr 2 '12 at 7:27
    
Just try to uninstall the Wi-Fi driver and then restart the system and install them again(I think windows-7 install it automatically). –  avirk Apr 2 '12 at 15:40
    
I'm experiencing the same problem on my Dell laptop, but never got around actually trying and fixing it. Thank you for your question (+1) as it may eventually help me as well. I'll try and see if I'm able to sort the problem out on my end so I can possibly help you ;-) –  extremko Apr 3 '12 at 12:02

14 Answers 14

Update (from OP):

As we could not solve this problem, we finally installed a USB WLAN adapter, and disabled the built-in adapater in the Windows device manager. This has solved the problems. So it looks like it was a problem with the built-in adapter.

share|improve this answer

your ADSL router could also be the issue here as it could be broadcasting in mixed mode using both frequency bands (ie. 2.4GHz - 5GHz). Broadcasting in both bands can cause conflicts and issues with connectivity. I would log in to your router and check the wireless frequency broadcast. I would also investigate the power settings on your router to verify the antenna strength is sufficient enough for the area you are using the machine in. I would also test out the issue while using a static IP/Subnet/Gateway/DNS/ to verify that your machine or DHCP isn't having any issues reissuing IP config settings.

If your problems still persist i would use a third party diagnostic tool to interrogate your system for faulty hardware or as a previous suggestion try out a wireless usb adapter to see if that will isolate the problem to a faulty NIC card.

If still continuing to drop connectivity i would see if there is an available NIC driver from the manufacturers website to see if that might correct the issues.

share|improve this answer

Try checking your antenna wires inside your laptop that they are FULLY intact. Any loose or overly bent wires will randomly stop your wireless from working, especially during whilst the laptop is moving. Either way, no harm in soldering them on properly if they look a bit delicate.

share|improve this answer

I had a problem my network fall down frequently. I use USB wifi adapter with connectify virtual router system on windows 7 32bit.

After doing a little research I found the problem it causes of power settings on control panel.

Please navigate the power options and go to advance power settings then set USB suspend mode to disabled. That's may help you.

Thanks,

Abbas

share|improve this answer

If you are using Skype, stop it on all computers. Skype was the problem cause in my home WLAN, it affected all connected devices.

share|improve this answer
    
Thanks for the hint. However, we do not use Skype. –  sleske Aug 14 '12 at 14:15

Try a fresh install of Windows, or Linux or alike. If the problem still persists it's probably a malfunctioning/broken wireless adapter.

Ensure the antennas are properly attached to the wireless adapter inside the notebook, and that they are routed properly and not damaged.

Try a replacement adapter.

share|improve this answer

There's probably interference on your channel. Try inSSIDer to see if your neighbors are on the same channel as you, and if so, change the channel your access point uses.

share|improve this answer

Wi-fi is very finicky when it comes to line of sight. You need to describe your geographical environment in terms of location from access point. For example, if you are close to the access point or if there are walls in the way. Wireless (2.4GHz) does not work that well through walls because it's a high frequency (in contrast to cellular technology which is amplified on a low frequency).

The way to isolate this potential problem is by moving your computer right next to the access point. If the problem goes away, alas, you have a line of sight problem.

share|improve this answer

Few years back i have faced the same problem ; In my case i have used Atheroes wireless card installed in my desktop PC in my college wifi network.

  • Consider the distance from the ADSL router to your laptop ( If signal strength is weak it is possible to drop your active connection automatically since you are running in energy saving mode.
  • In your router config window go to wireless option limit the maximum clients into 2 computers and fix a security key (Enter 192.168.1.1 in browser , and the address or procedure to enter your modem configuration panel may vary depends on your ADSL modem you are using ).
  • Now re-install the specific Atheroes driver again (And leave the atheroes control panel application )
  • Now Windows 7 will do the rest ,it will search for the network connections available.Now select your network and tick save password check box, Choose the option "Connect automatically" whenever your network is available.

So windows will try to automatically connect to your wireless network ,instead of troubleshooting .

If still problem persist , now try to connect your laptop using ethernet LAN cable through modem . Your ADSL modem working fine as you told , so you need to check weather your both network adapters are working fine or not ,to figure out the problem .

If you face the same problem in LAN connection again ,then problem may be with your windows drivers and recently installed drivers or viruses etc. The fresh re-install of your Operating system will sure help to resolve this issue

share|improve this answer

A few more questions as food for thought --

Does your network have a security system in place that might be disconnecting you from the network due to suspicious network behavior?

Does your laptop have a firewall that is shutting down the NIC?

Does this happen while moving the laptop between different wireless access poinst?

I saw drivers and software mentioned in this thread, but have you checked the firmware version?

What is your connection strength normally, when you have a good connection? (sometimes even a metal cart or person passing through the area can affect your connection if it is weak)

Is this new behavior, or has this been happening ever since you started using the wireless connection on this laptop?

share|improve this answer
    
All good points; unfortunately none apply :-(. Also, I expanded my question a bit in response. –  sleske Apr 3 '12 at 6:45
    
Unfortunately, I could not resolve my problem. Still, this answer has a lot of good points, so I'm awarding the bounty. Anyway, thanks everyone! I'll post again if I manage to resolve the problem. –  sleske Apr 8 '12 at 12:35

This might be a problem with the wifi channel you are using. If you have a router that is commonly used (like a fritz box or something like that), then its default channel might be swarmed with connections and interferences. Some routers have a graphical display to show the load of interferences on its channel. I suggest you to set the wifi to a more uncommon channel (like 12 or so) and look if the error persists.

share|improve this answer

Disable power management of the wireless adapter. I have seen this kind of flaky behavior before with wired network connections that were under power management by the OS.

  1. Open 'Computer Management'

  2. Highlight 'Device Manager'

  3. Expand 'Network Adapters'

  4. Right click the entry for 'Atheros AR5B125' and choose 'Properties'

  5. Click the 'Power Management' tab and uncheck all three boxes (especially "Allow the computer to turn off this device ...")

share|improve this answer
    
Good idea. Unfortunately, I have already disabled power management. Anyway, I'll check again to make sure. –  sleske Apr 2 '12 at 9:45

You could download the latest NIC driver from ATHEROS Wireless drivers for Windows. Search for the AR5B125 line and click on the green V sign for your version of Windows 7 (32-bit or 64-bit). Reboot after installation.

If installing the driver does not fix the problem, go into Windows Update and ensure that your computer is fully patched for both important and optional updates. Call Windows Update repeatedly as long as it can find anything to install.

It the problem still persists, it is worthwhile checking if the cause is not hardware. Find an external USB WiFi NIC and try it out. If this fixes the problem, then the built-in NIC is faulty, and the question then arises whether the computer is still under warranty.

A rather long shot is to see if this is caused by an installed application, by booting into Safe mode with network (which is rather painful to use).

share|improve this answer

Check to make sure you have the most current drivers for your NIC. Update if necessary.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.