Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old Dell Vostro 1510 with Ubuntu and Windows 7 on it. When it is switched on, it shows the following message:

NO TPM OR TPM HAS ERROR
SYSTEM BIOS SHADOWED
VIDEO BIOS SHADOWED

Then it waits on the same screen for about 70-80 seconds before showing up the grub. I read about tpm problems but did not get anything about shadowed problems. So my guess is tpm isn't the reason for this slow booting (am I right?) But then what is it exactly? Please help..

UPDATE

I also figured out (from video recording of the boot screen ;) that just before booting into the boot loader (grub2), 2 more messages are appended to the previous ones:

Fixed Disk 0: WDC VDxxxxx (my hard disk)
Mouse initialized

Does it mean that the time taken is in looking for the hard disk???

enter image description here

share|improve this question
    
Possible duplicate...superuser.com/questions/57090/no-tpm-or-tpm-has-problem –  Moab Mar 27 '12 at 21:06
    
Run the Dell Diagnostics from the hard drive...support.dell.com/support/edocs/systems/vos1510/en/SM/html/… –  Moab Mar 27 '12 at 21:10
    
@Moab: the real problem here is of slow booting and not TPM. And thanks for the link. –  haywire Apr 12 '12 at 1:58
    
the real problem was the dvd drive. I just disconnected the bus which was connecting it to Motheboard..and the boot time is 3-4 seconds now! :) –  haywire Apr 14 '12 at 18:03

3 Answers 3

up vote 1 down vote accepted

The problem was a faulty DVD drive. The motherboard kept on probing it for a long time while booting up, so I just disconnected the DVD drive bus from the motherboard and the system now boots up within seconds!

share|improve this answer

If you can deal with the formatting issue click on edit answer and look at the original post of the super long answer to get the important information that was edited out. The information that was edit out is critical for keeping your cool and dealing with the frustration of certain programs that you need, not working with other software. I would not use any answers that are not specific when it comes to flashing your bios.

share|improve this answer

The theme of this repair is to eliminate any interference so that we may get to the root cause of this problem. First, make sure the power plugged in. Then go into the BIOS, clear the settings back to factory defaults with no adjustments. Note what the version of the BIOS is. Then save, exit, and reboot.

If that doesn't work, then we can eliminate BIOS problems. Now we can find out if it's an OS problem. See if you can use an old hard drive for the install so you don't have to erase your data. Try a fresh install with whatever Windows disk you might have available.

While the install is running (or before the install if you don't have another computer), go to the driver page of the manufacturer's website and download the latest BIOS update. If you already have the newest version, then download the latest one and download the one before it, or the first version available.

When Windows is finished installing, transfer your BIOS updates to that machine. Now run the latest update - it should auto-run. If it doesn't run or if it says it's already the newest version then you have to copy the winphlash folder from C:\windows\temp to the desktop. Open the folder to run winphlash. When it starts up look for the Advanced button and click it. One of the options should be something like "check for or only flash newest version." Uncheck that box, then go back and select backup and flash. Now select flash and once it starts make sure you have power if it is a laptop. Don't touch the computer while the BIOS is flashing.

It should now say "flash successful;" if so, reboot. If that didn't fix the problem then repeat the flash process with the older BIOS update.

Okay now that we have the OS and BIOS covered, if you sill have boot problems then start to strip the hardware down one piece at a time. Through the process of elimination see if you have a hardware problem. If this is a desktop never rule anything out because if you do the problem will be what you overlooked.

share|improve this answer
    
i think i'll be going with stripping down option! :) Let me try it.. –  haywire Apr 12 '12 at 12:49
    
hey hey!! stripping down really worked!! the problem got fine as soon as i disconnected the dvd drive from the motherboard!! thanks @Monk! ur great wall of text wasn't that bad in the end!! thanks :) –  haywire Apr 14 '12 at 18:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.