Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a hard drive with a long obscure folder name (26b72166e9fa7bae09463d5c6f90e4) and subfolders i386 & amd64.

After googling, it seems that it may have been related to various updates/drivers. Right now I just want to get rid of it. This drive is just used for data storage. There is no OS on it.

When I try to delete, the error message says that I do not have permission. When I go to the security tab, I don't have permission to view or edit the objects permission settings.


Edit: Add Spybot Secure Shredder to the growing list of non-working solutions.

share|improve this question
I would recommend changing the 'winodws' tag to the 'windows' tag. – Richard Marquez Sep 13 '09 at 16:17
@Rich, oops ... thx! – Keith Bentrup Sep 13 '09 at 16:27
up vote 2 down vote accepted

Boot on a LiveCD that support NTFS. I guess most of the Linux live distros can do it (Ubuntu for instance).

From Linux, you should be able to browse your Windows disk and delete the rogue directory.

share|improve this answer
I thought about doing this, but I was hoping for a quick answer to do it natively in windows. This may be the only solution, but it requires downloading the ISO if you don't have one handy then burning a CD, then shutting down and booting into another OS, then shutting down and booting back. Plus, if you're using your machine as a server OR in the middle of a some long process, you have to wait or interrupt your work. Sigh ... – Keith Bentrup Sep 13 '09 at 17:31
It is always a good idea to have a liveCD hanging around. I use a USB stick I don't need anymore, it's come in handy in many a strange situation. (Need to order pizza, but the phone is dead and the PC won't boot? SOLUTION. (seriously, the phone didn't work. Line was fine, the phone was in two pieces :()) – Phoshi Sep 13 '09 at 17:32
Ok, this worked. Fortunately, I run Ubuntu virtual machines, so I was able to save myself the trouble of downloading an ISO. I just burned an image from that. Had to change the boot order in my BIOS though ... sigh. I blame Microsoft for turning a simple task into an ordeal. – Keith Bentrup Sep 13 '09 at 17:51
You could also have booted the Vista CD in the Vista Recovery Environment and started a Command Prompt. See this link: – Snark Sep 13 '09 at 18:16
@Snark, perhaps if the PC manufacturer had given me a Vista DVD. – Keith Bentrup Sep 13 '09 at 19:06

I would first try booting into safe mode as the Administrator. You might be able to delete it then.

Also, have you tried deleting it through the Windows command line? I find that sometimes works around finicky Windows issues like this.

share|improve this answer
Booting into safe mode doesn't work. Neither does deleting thru the command line. Thx, though. – Keith Bentrup Sep 13 '09 at 16:52

If this update hasn't yet been fully applied the files may still be neccessary. If however the update has been applied then you can delete the files.

The Windows Update or BITS services might be locking these files but you can verify what, if anything has a reference to these files using SysInternals FileMon or ProcMon

share|improve this answer
It may have be the remnant of an update, but it's definitely not in use any more. It's just a drive that I use for data. I haven't even had it connected for a while. – Keith Bentrup Sep 13 '09 at 17:43

This thread discusses the problem and a solution as below.

I am running Windows XP/SP2 and was able to delete the rogue folder this way:

1) Disable simple file sharing a. In the Control Panel, Select Folder Options, then select the View Tab b. Scroll down to the end and uncheck the box next to "Use simple file sharing (Recommended)" c. Click Apply, OK, and exit Control Panel. 2) Change permissions of rogue folder a. Navigate to the ed798b66cbeb3a7b9bde9e55a9e2 folder left behind from the .NET framework update b. Right click the folder, select Permissions, then select the Security tab c. Under the "Allow" column, click the first box for "Full Control". All the boxes (or at least most of them) will automatically get checked. d. Click Apply then OK. 3) Drag rogue folder to the Recycle Bin. This should delete without a problem. I told this solution to a friend and he had to go into the rogue folder and perform step #2 for both the folders present for some reason, but the end result was the same. The offending folder got deleted.

share|improve this answer
These are instructions for XP, but I did the corresponding actions in Vista, and no luck. – Keith Bentrup Sep 13 '09 at 17:03
@Keith, have you checked that you actually have sufficient permissions? – nik Sep 13 '09 at 17:26
@Nik, do you mean, "Did I try this as an administrator?" Yes. – Keith Bentrup Sep 13 '09 at 17:38
This is odd. If Windows has not locked the files (which Unlocker would probably open) and you have sufficient permissions on the station, deleting the files should not be a problem. – nik Sep 13 '09 at 17:49

Such files are typically left around by Windows Update.
If following Matthew's advice doesn't solve the problem, get Unlocker. But first verify which is the process that's hogging this directory, just in case.

share|improve this answer
Unfortunately, Unlocker is not XP/Vista 64bit compatible. – Keith Bentrup Sep 13 '09 at 16:54
Also, I don't think it's related to a process that's preventing the deletion. – Keith Bentrup Sep 13 '09 at 17:08
@Keith: it is now, since version 1.9.0 (see the same FAQ) – onnodb Nov 13 '10 at 9:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.