Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 4X 2GB RAM sticks installed, Windows 7 Ultimate x64 shows "Installed Memory (RAM): 8GB (4GB Useable)" in the system information. The motherboard says it supports up to 16GB of memory. I had Windows XP x64 and I'm pretty sure it was able to use all 8Gigs of memory. I've just formatted and am not burning through 4GB for sure.

*The BIOS only show 4096MB while booting.
I was only able to find one option relating to memory mapping and it took it from 4Gigs to 3 and change.
CPU-Z shows all 4 sticks as 2048MB
I went in to msconfig and checked the limits, they are not set.
I tried resetting the CPU and RAM sticks 3 times, the CPU has no pins to be bent (flat contacts, I5)
I rearranged all the RAM.
I have separate video memory from the system memory.
I have a 64 bit OS (I am 100% certain)

Hardware:
Memory: Four Corsair XMS3 TW3X4G1333C9AG
Motherboard: Asus P7P55D Pro
CPU: Intel Core i5-760 BX80605I5760
Graphics: Two ZOTAC ZT-50401-10L GeForce GTX 550 Ti

If anyone has new ideas or knows the exact setting in the bios, it would be greatly appreciated.

share|improve this question
    
It appears that the motherboard thinks it's running in 32-bit mode. I have no idea why this is happening, though. – jsejcksn Mar 28 '12 at 3:32
1  
It's been a while, but did you find a solution? – Pao Aug 26 '13 at 20:36

Make sure the Memory Remapping BIOS setting in the Advanced tab is enabled:

enter image description here

share|improve this answer
    
Where?​​​​​​​​​ – Synetech Mar 28 '12 at 21:56
3  
It should be in the BIOS. – David Schwartz Mar 28 '12 at 22:19
2  
+1, though strictly speaking the memory remapping should only affect PAE and other 32bit configurations. AFAIK it wouldn't affect an x64 system. – 0xC0000022L Mar 29 '12 at 0:52
    
Memory remapping affects an x64 system. If the memory isn't remapped, the OS can't access it. – David Schwartz Mar 29 '12 at 1:09
    
That setting is in the BIOS, on boot push delete when asked then go to Advanced>Uncore Configuration>Memory Remap Feature. Unfourtunately that image is exactly what mine looks like including the "4GB To 3328MB" and the "Enabled" parts even though I have 8GB. – Mike Bannister Mar 29 '12 at 2:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .