Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Firefox (12.0 beta), and whenever a video is available in HTML5, it will open in that. I have opted-out of the HTML5 preview (I saw a post suggesting to opt-in then opt-out again, which I did... this had no effect). I want to force it to use the Flash Player always.

EDIT: I'm using Windows 7.

Thanks!

share|improve this question
    
Is Firefix without webm support is out of the question? –  Eroen Mar 28 '12 at 7:03
    
Are you sure Flash is installed and enabled properly? Check about:plugins and a Flash test page e.g. Adobe's test page or a Flash based game. –  Bob Mar 28 '12 at 7:45
1  
@Eroen - No, if I can somehow remove the WebM support from Firefox that would be fine. –  OverMachoGrande Mar 28 '12 at 9:19
1  
@Bob - Yes; it uses Flash on videos that don't have WebM versions (most of them). I want to use it on all videos it can be used on. –  OverMachoGrande Mar 28 '12 at 9:19
    
@Fraser I meant to put the word "compiling" in there somewhere. I'm hesitant to put it as an answer, as I really hope there is a configuration solution. –  Eroen Mar 28 '12 at 9:52

1 Answer 1

up vote 11 down vote accepted

In the comments for this enhancement request there is a suggestion (comment 5 at 2012-03-13 15:57:41) to set media.webm.enabled, media.ogg.enabled and media.wave.enabled to false in order to "render <video> and '' elements unable to play anything."

All these options are readily available if you enter about:config in the address box, and then enter media. in the filter box. In my testing (Firefox 10.0.1 on Gentoo) it was not necessary to restart Firefox, the elements were disabled when I reloaded the page.

This page was useful for my tests. The video there is disabled when both media.webm.enabled and media.ogg.enabled are set to false, as there is fallback from one to the other.

There were rumors reently that future Firefox will support h.264, in that case you might have to disable that too after an update.

share|improve this answer
    
Shweet; thanks! –  OverMachoGrande Mar 30 '12 at 13:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.