Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use tools like Tunnelier to log into my home Tomato router through SSH, and then use it as a proxy for web browsing, tunnel for Remote Desktop/VNC, etc.

Most days it works great, but some days every page I try to view gets stuck, like the tunnel is clogged. I load a web page and it seems to be loading, then stops, with the little loading icon spinning and nothing happening.

enter image description here

I refresh the page, I reboot the router, I reboot the other computers on my home network and turn off any bandwidth-hogging services on them, I've turned on QoS on the router to prioritize SSH. I don't understand what's getting stuck. Rebooting or disconnecting/reconnecting the SSH tunnel improves responsiveness for a minute, but then it gets clogged again. It also seems to help if I don't do anything on the tunnel for a few minutes, then it will be responsive for a bit and then get clogged again.

Trying to open a terminal console from Tunnelier is also unresponsive, so it's not just a web browsing problem. Likewise, connecting to http://192.168.1.1 in the browser (to the router's web config through its own tunnel) is also slow/laggy/halting.

If I open a second connection through PuTTY and run od -t x1 /dev/urandom, it will sit there dumping numbers with no freezes, while the other terminal and web browsing through Tunnelier is frozen and unresponsive.

The realtime bandwidth reported by the router is nowhere near my DSL PPPoE connection's limits, though it does show big spikes during the laggy times, and the connection is responsive when it shows low bandwidths.

How do I troubleshoot something like this?

share|improve this question
    
This sounds similar: unix.stackexchange.com/q/20061/19012 –  endolith May 18 '12 at 14:40
    
Ooh! If I connect to my computer on my home network, the tunnel works a lot better. Tunneling through the router alone is slow and cloggy, but tunneling through the router, through an Ubuntu computer, and back through the router works better?? –  endolith Jul 24 '12 at 15:09

2 Answers 2

Do you see any errors on the router for dropped packets?

SSH or telnet into the router and type ifconfig. Look for interfaces with non-zero errors. I can consistently get errors when I use an SSH tunnel when my DSL uses an MLPPP link. I believe there is a bug in the firmware or MTU issue.

For my issue, I switch off MLPPP when tunneling a lot of traffic through ssh. See sample output with errors on the RX.

ppp0       Link encap:Point-to-Point Protocol  
           inet addr:X.X.X.X  P-t-P:X.X.X.X  Mask:255.255.255.255
           UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
           RX packets:902164 errors:7328 dropped:7328 overruns:0 frame:0
           TX packets:801796 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:3 
           RX bytes:930052499 (886.9 MiB)  TX bytes:447000060 (426.2 MiB)
share|improve this answer
    
Today, the only one with errors is eth1: "TX packets:560416 errors:102 dropped:0 overruns:0 carrier:0". The other interfaces are all 0 errors. eth1 is the Wi-Fi, though, which shouldn't be involved with the SSH tunnel. The SSH tunnel is working today, anyway, but I'll check this next time I'm having problems. –  endolith Mar 29 '12 at 17:54

Check your MTU of your DSL and VPN tunnel. Adjust down. DSL should be less than 1492. For MLPPP should be around 1487 because of the MLPPP framing overhead. Also check your router MTU settings for 1492 and NOT 1500 (broadband cable)

Matt

share|improve this answer
    
It's set for 1492 on the router –  endolith Jun 11 '13 at 3:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.