Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been following (among others) these instructions to setup a Mozilla sync server. It runs fine when I connect to

http://mydomain.com:5000/

but when I use https instead of http and remove the :5000 I get an error 500 returned without any error logfile entries.

I set the logfile levels to DEBUG in all related logs (apache, Mozilla Sync), but I cannot track down where the issue lies. For example, the only entry in the debug-level apache-logfile relating to wsgi is:

[info] mod_wsgi (pid=30174): Create interpreter 'mydomain.com|'.

I want to use SSL to encrypt the username & password which are otherwise transmitted in clear text.

Please note that I have not too much of a clue how wsgi works and how it interacts with apache.

share|improve this question

2 Answers 2

I had lots of trouble with the rather ambiguous 500 error recently. While I might not be able to solve your problem, I can point out the troubles I ran into.

The wenks.ch guide was the best one I could find, but I needed to change one little detail (at least on my system): the author reduces his pool_size and appends a comment explaining why; in my case I had to move this comment to the next line, otherwise I would get a 500 error. However, this error showed up in what the author of the guide describes as /usr/local/www/mozilla-sync.example.com/logs/error-https.log .

Another problem I ran into was that my permissions were not set up correctly. Perhaps try to loosen permissions a bit to see if that helps (especially etc/mozilla-sync.conf and tmp/sync-error.log in the guide, this gave me KeyError: backend in the same error log mentioned in the above paragraph).

A guess of mine would be to adjust the fallback_node accordingly, if you're going to access it through https then maybe it should be https://mydomain.com/ .

Maybe the Apache configuration needs updating as well. Port and certificate come to mind.

If this does not help, maybe try splitting it up - see whether you can connect properly to the server using https using the default-ssl configuration, and whether you can change the port number from 5000 to something else (not using ssl). If nothing else, check the guide again.

Hope that helps!

share|improve this answer
up vote 0 down vote accepted

I finally found the solution to the issue here:

500 Errors when communicating with Firefox Sync Server through mod_wsgi and Apache2

You need to delete the weave error log since the one that is created by the parser prevents WSGI to write to it due to permission errors. That creates the 500 error.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.