Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I used Google voice to make a call, the other side informed me that he could hear his echo. The reason is that I was using my laptop's internal microphone as input and internal audio stereo as output for me, which could send back any sound played out by the internal stereo. So I wonder how to prevent the other side can hear his echo? Thanks!

share|improve this question
8  
The simplest solution would be to use headphones. – iglvzx Mar 28 '12 at 21:40
    
Use directional microphone or headphones? – Lazy Badger Mar 28 '12 at 21:48
    
Thanks, @iglvzx and @Lazy! I will try to buy a headphone. Is there any simple way to mute the microphone on my side when the other is speaking? I know I can click the microphone button of google talk, but just for quicker switch between mute and unmute, I wonder if there is a quicker way, such as a shortcut key or something? – Tim Mar 28 '12 at 21:56

I had the same problem. I fixed it by turning on echo cancellation on the device. I am using Windows 7. It is under the properties setting on the microphone. I have made two phone calls now and the echo on the other end is gone. They no longer here their voice echo. I hope this helps.

share|improve this answer

According to my experience, if you hear an echo while talking, the problem is likely to be on your contact's end. Try to reduce the microphone and speaker volume to see if it helps. Also, you may change the speaker orientation on both sides to ensure that the speakers are not too close to the microphone. It's also possible for one side to mute while the other side is talking. Hope it helps.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .