Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I save files from e.g. remote desktop or from an email (outlook) attachments, or from skype even to my local machine they show a locked Icon on the file. Then e.g. SQL Server doesn't let me restore backups as it says the operating system doesn't have access to the file.

I've had success fixing this by setting the ownership of the parent folder to my user and then let it apply to sub folders. Also sometimes I need to click -> Proerties -> Security -> Advanced -> Change Permmissions, then check "change child permissions..." and apply on the parent dir.

I'm using Windows 7 64 bit Proffessional, on HP Probook 4530, and I have a administrator user.

This is a real pain to do everytime. I suspect it might be because of HP software that came with the laptop, I think there is drive encryption as part of the protect tools. Although I'm hoping there's something in windows i can set to change the behaviour to not lock these files.

share|improve this question
    
This is a 'feature' of the NTFS filesystem that has been in use since Windows 2000. –  Justin Pearce Mar 29 '12 at 14:38
    
It wasn't a problem on my previous laptop or any other windows 7 or windows vista pc I have. Is there a setting somewhere to change the behavior? –  John Mar 30 '12 at 6:22
add comment

1 Answer

up vote 1 down vote accepted

It seems I may have solved the issue by setting myself as the owner on the root drive and applying full control permissions on all sub folders.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.