Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Plain Mac OS X installation (10.6.8), and all of a sudden the audio stopped working. I get visual feedback upon changing volume with the keyboard, and the icon in the top right reports that audio is at full volume. Internal speakers are handling sound. Ask for more information if you need it... I'm not sure what else to give.

Thoughts?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Look in Activity Monitor to see if coreaudiod is running properly, if not there may be problems there.

You may also try re-installing Mac OS X from the discs that came with your computer, or you can install a virtual machine and run another OS through it to see if you get sound to function correctly.

If it is hardware, you could try a PRAM reset (do this before the re-install idea), if you don't know what that is then at start up hold Cmd+Alt+P+R, wait for four start up chimes, then stop.

You could also reset SMC, but I don't think it will do anything.

share|improve this answer
    
Thank you! The audio daemon was not running. –  tekknolagi Jun 12 '12 at 22:21
    
I figured this out a while after I asked and forgot to close the question. –  tekknolagi Jun 12 '12 at 22:21
add comment

Try going to system preferences > sound > output and making sure Internal speakers is selected.

share|improve this answer
    
And try listening through the earphone connector. (And consider that the switch in the earphone connector may be stuck in "earphone" mode.) –  Daniel R Hicks Mar 31 '12 at 3:00
    
Cole, did you even read the question? "Internal speakers are handling sound." –  tekknolagi Mar 31 '12 at 5:13
    
Also I will try that, DanH –  tekknolagi Mar 31 '12 at 5:53
    
@tekknolagi Yes I did read it. By internal speakers are handling sound I assumed that that meant you were expecting to hear sound from them but it wasn't working. Is that assumption incorrect? –  Cole Mar 31 '12 at 17:11
    
Nope. They were selected to handle sound in the System Preferences. –  tekknolagi Mar 31 '12 at 23:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.