Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to run a web browser on my desktop machine at work but display on my local laptop.

To connect via ssh, I need to go through 2 servers.

  • A: Laptop wanting to display browser that runs on D.
  • Server1
  • Server2
  • D: Desktop with browser installed

I've tried all sorts of combinations to get X forwarded through each host with no luck, X11Forwarding is enabled on all hosts and does work when the 2 servers are not involved.

Essentially, something like;

ssh -X user@server1 ssh -X user@server2 ssh -X user@desktop

Then I'd like to be able to launch applications on D but display on A.

when doing echo $DISPLAY on D, the display is not set, it seems to be 'lost' on server2.

Server1$ echo $DISPLAY
localhost:10.0
Server1$ ssh -X user@server2

Server2$ echo $DISPLAY

Server2$

Many thanks

share|improve this question

migrated from stackoverflow.com Mar 30 '12 at 1:08

This question came from our site for professional and enthusiast programmers.

    
The ssh daemons on the relays are probably not configured for X11 forwarding. – datenwolf Mar 27 '12 at 20:49
    
All hosts are enabled for X11 forwarding whist attempting. – Luke B Mar 28 '12 at 8:19
    
Did you check /etc/sshd_config for this? Also are all proxies configured for localhost display? – datenwolf Mar 28 '12 at 9:58
    
X11Forwarding yes AllowTCPForwarding yes – Luke B Mar 28 '12 at 13:15
    
I added some -v's and found out no xauth is on one of the proxies. – Luke B Mar 28 '12 at 13:19
up vote 2 down vote accepted

xauth missing on proxy, discovered missing by adding -v to my ssh command.

share|improve this answer

You must log in to answer this question.