Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's a puzzle.

Last year I bought some hosting from a hosting company and pointed a number of domains that I own to run from this service. All domains working fine and publicly accessible.

Then a few months ago I was at home and realised that I could not view any of the sites. The browser would report an error. I assumed a temporary glitch. Back in the office, from my office machine and network, all the sites worked just fine. Back at home that same day, none of the sites worked. I tried multiple browsers on the same home machine, clearing the caches, restarting the machines, restarting the router, tried other machines on my home network, even tried an iPod - not a sausage. None of the sites would load. However, when I tried accessing them from my Blackberry I could see they were all working.

A few weeks ago, the sites started working again from home ... but then a day later had stopped! And that is the current situation. I cannot access the sites from home but they work from the office and indeed seem to work for any other user. One of the sites is for a local sports club - Godalming Badminton Club - try it yourself. If you have any problem let me know but I tried it just now from the office and it works and I am told by other users it has been working consistently over this period.

So it would appear that there is some problem with my local network or ISP. I use a cable connection from Virgin Media, connected to a Dlink DIR655 router/gateway/switch. I use OpenDNS instead of the default ISP DNS but that is one thing I have checked. I tried reverting to the default ISP DNS but it made no difference.

I used to think I was pretty savvy about this kind of this kind of thing but now I think I may have missed something obvious. Please could somebody suggest some steps to diagnose the source of this problem and/or tell me how to fix it!!

share|improve this question
    
I think this belongs to webapps. –  Michael K Mar 30 '12 at 8:17
    
@Michael K: Webapps is for questions about web apps (Gmail, Google, Facebook, Blogger, Flickr, Twitter, etc.). This question is about networking. It might belong on Serverfault, but the problem seems more home networking related than server/network administration related. So Superuser would be the best place for it. –  Lèse majesté Mar 30 '12 at 8:31
    
@Lèse majesté you may be right with this, without knowing what causes the problem it is a bit hard to categorize. If it is a problem with the cms of the site, it would belong on webapps, right? –  Michael K Mar 30 '12 at 8:35
    
@Bish I can access the page without any problems. I recommend you to check you home network and try to trace the way to the site (tracert on windows...) –  Michael K Mar 30 '12 at 8:35
    
@Michael K: It could be. A more detailed description of the error is required. –  Lèse majesté Mar 30 '12 at 8:39

2 Answers 2

You don't mention OS, but I'll assume Windows (it will be simpler if it's not, but people who don't mention OS are usually on Windows ;-) ).


Open a command prompt (Run -> cmd) and run

ping www.godalmingbc.com

and see which IP number it looks up. For me, this gives

PING godalmingbc.com (50.28.10.63) 56(84) bytes of data.
64 bytes from host100.kvchosting.com (50.28.10.63): icmp_req=1 ttl=49 time=135 ms

If your computer looks this up to a different IP, you should try to find out why (try the command from one of your devices that work).

You say that you tried different DNS servers. Try it again, and make sure the change actually initiates, i.e. save settings, reboot router and so on. Try DNS 8.8.8.8 (Google's public DNS), which demonstrably resolves to the correct IP:

$ nslookup www.godalmingbc.com 8.8.8.8
Server:     8.8.8.8
Address:    8.8.8.8#53

Non-authoritative answer:
www.godalmingbc.com canonical name = godalmingbc.com.
Name:   godalmingbc.com
Address: 50.28.10.63

If it was just a single machine on your home network that had the problem, I would tell you to check the hosts file to see that there wasn't a rogue entry there, but unless you have an unnecessarily convoluted home network setup, this would probably only affect just a single machine (unless you have permeated the change to all hosts files, but you should be aware if this, I reckon).

share|improve this answer
    
Thank you for your suggestions. I have mixed Windows 7 and XP on home machines. Ping returned the correct IP addres - the same as the one you list. I will try the Google DNS but as mentioned, I have tried OpendDNS and the default ISP DNS, rebooted the router and it makes no difference. I cannot browse using the IP address either. DNS does not appear to be the problem. I cannot browse using the IP address either. I have checked the hosts files and they are clean. –  Bish Mar 30 '12 at 8:41

You may be seeing a block on your hosting provider's firewall or even a firewall on your server. I know some of the turn-key solution cpanel firewalls are notorious for locking admins out of their own websites. There's the possibility that your network segment was blocked by the hosting provider at the edge to mitigate a DoS attack. Try opening a ticket with your hosting provider.

share|improve this answer
    
Thanks for the idea. I have been in touch with the hosting provider and as far as they are concerned there is nothing wrong. And I can't argue, as all the sites, including the CPanel access work fine from all other networks. :( –  Bish Mar 30 '12 at 14:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.