Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I routinely visit pages like http://trac.server/milestone/Milestone Name Here. In Firefox (11.0 on Ubuntu, but this has happened for a while), the URL is displayed as trac.server/milestone/Milestone Name Here (without the protocol).

If I then click into the URL bar (either to edit the URL, or just to resubmit it), and press Enter, then the spaces are assumed to indicate that I'm searching, and I get a nice Google search page trying to look for trac.server/milestone/Milestone Name Here. For extra points, this search page gets saved in my history results.

If I manually add the http:// at the front of the URL, then the search is submitted correctly. But I don't want to have to do that.

This is annoying and time-wasting. How can I avoid this?

share|improve this question
add comment

1 Answer

One option is to turn off the URL trimming (see this question): setting browser.urlbar.trimURLs to false in about:config.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.