Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running a virtual machine at home which has a VPN connection to our main office, but I also want to connect to a share on another machine at home.

When I check with IPCONFIG I can see two ethernet connections ...

my work VPN ...

Ethernet adapter Local Area Connection* 11:
   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : xxxx::xxxx:xxxx:xxxx:xxxxxxx
   IPv4 Address. . . . . . . . . . . : XXX.XXX.XXX.XXX
   Subnet Mask . . . . . . . . . . . : 255.255.254.0
   Default Gateway . . . . . . . . . : XXX.XXX.XXX.XXX

and home local ...

Ethernet adapter Local Area Connection:
   Connection-specific DNS Suffix  . : lan
   Link-local IPv6 Address . . . . . : xxxx::xxxx:xxxx:xxxx:xxxxxxx
   IPv4 Address. . . . . . . . . . . : 192.168.1.70
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

What's weird is when I've been working before with a plugged-in ethernet cable I've not had any problem getting to the share?

I can PING the other machine, but I can't access the share at ... \\othermachine\c$ I tried 'TRACERT` but that disappears off to the work network and eventually gets back to the local other machine after a few time-outs

Is there anyway to "force" the connection to stay local ?

UPDATE: the VPN is AEP SSL Tunnel

share|improve this question
add comment

2 Answers

The determining factor is your DEFAULT GATEWAY. Depending on the VPN client you are using, your ability to change the Default Gateway may be restricted whenever you are on the VPN. Most default configurations in CISCO, Juniper, or OpenVPN VPN's do not permit you to select anything OTHER than the remote gateway.

share|improve this answer
    
Weird, I've disconnected the AEP Tunnel, couldn't find any setting to change Default Gateway, reconnected and I can now ping the other local machine on IP6, and also access the share !! –  SteveC Mar 30 '12 at 16:46
add comment

You want to configure split tunneling between your VPN and home network.

  1. Disconnect your VPN

  2. Open your VPN connection properties

  3. Click the 'Networking' tab

  4. Select 'Internet Protocol Version 4' and click 'Properties'

  5. Click "Advanced'

  6. Uncheck 'Use default gateway on remote network'

  7. Press 'OK' to close Advanced settings, 'OK' to close Internet Protocol Version 4 settings, and 'OK' to close connection properties.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.