Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ok so let me explain, i bought WRT54G and successfully installed DD-WRT v24-sp1 (07/26/08) mini-special - build 9994. That's all ok no problems with it all normal functioning. And just to add (i don't need wireless, wireless is turned off always)

What i want:
ISP's router (TG782) from it's INTERNET port(out) cable "which was before in my pc" is connected to WRT54G's INTERNET port and then from WRT54G LAN port 1 to my pc.

The problem: How do i connect and setup all? I have tried many times on many different ways but cant get it to work IF THE CABLE FROM TG782 IS CONNECTED TO WRT54G ON INTERNET PORT.

If i connect the TG782 to Lan port 1 on WRT54G and my pc to lan port 2 then all works fine after i setup gateway and all. But i want to connect TG782 to Internet port of WRT54G because i need "Access Restrictions" and this only goes through WAN right? please correct me if i am wrong.

What i have tried:
This is how i have tried to setup all. The TG782 router ip is 192.168.1.1
And WRT54G ip is 192.168.1.30 so in WRT54G control panel i have setup like this:

----WAN Connection Type----
Connection Type: Automatic Configuration - DHCP
STP: Disabled
----Router IP----
Local IP Address: 192.168.1.30
Subnet Mask: 255.255.255.0
Gateway: 192.168.1.1 (the TG782)
----Network Address Server Settings (DHCP)----
DHCP Type: DHCP Server
Start IP Address: 192.168.1.100
Maximum DHCP Users: 6

And this wont work i probably miss something more, if anyone can help i would be thankfull. Also i have to note that i have tried to set my network adapter on pc to use the gateway of WRT54G and ip 192.168.1.102

In short: i cant get it to work normal only as a switch!

Thanks for any help!

-------EDIT:-------

Here is an image which maybe can help: http://img27.imageshack.us/img27/4227/allin1w.jpg

share|improve this question
add comment

2 Answers 2

Make the subnet between the TG782 and the WRT54G different than what's on the LAN side of the WRT54G.

Ie: If the DHCP server on the TG is handing out 192.168.1.X (255.255.255.0), then have the DHCP server on the WRT hand out something like 192.168.2.X (255.255.255.0).

If the network (segments) are the same on both sides of the WRT router it may be confused on how to route traffic, as it's expecting to find a different network on each side.

share|improve this answer
    
i tried this also, have found something what you describe dd-wrt.com/wiki/index.php/Access_To_Modem_Configuration but again no help, please take a look to image i have added in question. Thanks –  FeRtoll Mar 31 '12 at 11:17
add comment
up vote 0 down vote accepted

SOLVED IT

Upgraded to: DD-WRT v24-sp2 (10/10/09) std - build 13064

Main router from ISP:
IP: 192.168.1.1
Range: 1.100 to 1.200

WRT54G:

---WAN Setup---
WAN Connection Type: Static IP:
WAN IP Address: 192.168.1.102
Subnet: 255.255.255.0
Gateway: 192.168.1.1

---Network Setup---
Router IP: 192.168.2.2
Subnet: 255.255.255.0
Gateway: 192.168.1.1

I have tried that even before but wasnt working with old firmware.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.