Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a mac (called 'maxw-hackbook') with a folder (called 'work') which i've shared, making it "read & write" by me, "staff" and everyone. I've then mounted it to a folder on my ubuntu laptop, as follows:

#on ubuntu laptop
$ smbtree -s
WORKGROUP
\\MAXW-HACKBOOK         maxw-hackbook
    \\MAXW-HACKBOOK\IPC$            IPC Service (maxw-hackbook)
    \\MAXW-HACKBOOK\work            work

 $ sudo smbmount //MAX-HACKBOOK/work/ /mnt/hackbook-work -o ip=192.168.1.228,username=Max,password=passwordonmacbook,w

This has successfully mounted the "work" folder on the macbook to the /mnt/hackbook-work folder in ubuntu. But, it's read-only, even though i've set the shared folder (on the mac) to be "read and write" by everybody.

I need to have write access to that folder on the mac. Can anybody see what i've done wrong?

thanks, max

share|improve this question
1  
I assume you meant "MAXW-HACKBOOK" instead of "MAX-HACKBOOK", and that you used the "rw" mount option and not "w" as you wrote above? –  Kyle Jones Mar 31 '12 at 0:07
    
You assume i know what i'm doing :) I redid it with the right name, still no joy. But then just realised that i need to set the file permissions on the folders in the mac as well. I did chmod -R a+w work and that fixed it. How was i even able to mount it with the wrong name (MAX-HACKBOOK), is what i'm wondering now. Thanks! –  Max Williams Mar 31 '12 at 8:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.