Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to reset the BIOS password of an Acer Aspire One NAV50 netbook. I know that the password is stored in CMOS and I need to invalidate its settings. I want to know if software compatible with Windows 7 exists to reset the password for me (I can still login to Windows 7 as an administrator) because I don't want to fidgit with opening motherboards and the like.

share|improve this question
On desktops you can just pull the CMOS battery for 30 seconds to default the BIOS (little watch battery on the motherboard). May not work that way on a laptop though. Maybe theres a jumper you can move or pins that can be shorted, I dunno. – conspiritech Mar 31 '12 at 12:44
Used this guide on my Aspire 3620, worked… – Moab Mar 31 '12 at 13:59
up vote 3 down vote accepted

CmosPwd can grab the password from quite a large number of BIOSes. If it works on yours, you can get the password and use it to get into the BIOS, then reset from in there. It does not do any harm to try, since it's just for reading the password, not changing/writing/resetting it.

Alternatively, a BIOS flash might work. I'm unsure, and it could just brick your computer, so better to wait for someone else to answer if CmosPwd does not work.

share|improve this answer
Once, BIOS flashing worked for me.. not sure, it'd work for all. – Evil Angel Mar 31 '12 at 7:15
CMosPwd fails to install properly in windows 7 with admin account and UAC off. The error is StartService Function call failed. And when i try manually using net start ioperm , i get error: system error 2 has occured. The system cannot find file specified. – Dr Deo Mar 31 '12 at 7:56
Ah, unfortunately ioperm.sys seems to be 32-bit only. In other words, it won't work on 64-bit Windows. I've just checked, it works for me on a 32-bit Win7 netbook, but not on my 64-bit desktop. Your only real option if you still wish to use CmosPwd would be to run it off a bootable disc, most likely a Linux LiveCD. Or try to find a 54-bit port of ioperm.sys, you may be luckier with Google than I was. – Bob Mar 31 '12 at 10:00
For lack of time i went the hardware way by short circuiting some pins on motherboard below the ram. I had hoped there was an easier way. Thanks anywayh – Dr Deo Apr 1 '12 at 9:27
@DrDeo So why did you mark this the Answer?? – Moab Jul 22 '15 at 14:10

There are a few software which can also reset CMOS settings or BIOS password or both within a few clicks. But as stated above you should have access to a system which is turned on and should have access to MS DOS or MS Windows:



share|improve this answer
CMosPwd not working and killcmos seems to be a dos program that has just failed to work. Is there a solution designed with windows 7 in mind? – Dr Deo Mar 31 '12 at 7:57
ok. try this link which has a iso file download named "PC CMOS Cleaner". link- – Ghost Answer Mar 31 '12 at 8:07

There's a tool called CMOS De-Animator that runs even under 64-bit systems. If that won't work, there's an integrated make-bootable wizard in it, which has some functionality to decipher certain Acer laptops.

You need to take care though: as the author says, certain BIOS revisions check for unauthorized CMOS port I/O and lock themselves up upon next re-boot.

The password can also be stored in a separate EEPROM, away from the actual CMOS data.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .