Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got two VMware Workstation virtual machines running ...

Virtual A can ping the host laptop most of the time, other real machines on my home network all of the time, but it gets a "request timed out" for virtual B

Virtual B can ping the host laptop most of the time, and the machines, both real and virtual A all of the time

The only difference I know of is virtual B has been joined to my works domain, whereas virtual A is still in workgroup mode

Can anyone explain how / why this is occurring ?

Update ... these are all while my laptop is on wireless
Ping from ... host laptop (win7, workgroup)

  • To other machine on network (win7, workgroup) - OK
  • To virtual A (win2008 r2, workgroup) - mainly OK, do go some Request timed out
  • To virtual B (win7, domain) - just get Request timed out

Ping from ... virtual A

  • To other machine on network - OK
  • To virtual B - OK
  • To host laptop ... goes through pattern of a few Request timed out, next ping takes 2000ms, then next few take <1ms, then a Destination host unreachable and back to Request timed out

Ping from ... virtual B

  • To other machine on network - OK
  • To virtual A - OK
  • To host laptop ... similar pattern of a few Request timed out, next ping takes 2000ms, then next few take <1ms, and back to Request timed out ... but no Destination host unreachable

Ping from ... other machine on network

  • To virtual A - OK
  • To virtual B - just get Request timed out
  • To host laptop ... OK

I find it very puzzling that the virtual machine seem to have a hard time pinging the host laptop which they are running on, but are fine with another real machine on the network ?

share|improve this question
1  
I don't know Windows 7 that well but, a possibility- is firewall on Virtual B blocking ping/icmp? sysprobs.com/enable-ping-reply-windows-7 Also, can host ping A and not B? –  barlop Mar 31 '12 at 10:17

1 Answer 1

up vote 4 down vote accepted

I think what Barlop says in comments is the most likely cause.

Your question asked why this is happening... When you connect to a network, Windows asks you to select a location - public, home or office.

Each profile has different default firewall walls, although I don't remember them blocking ping by default other than on Windows Server (but, I am probably wrong - been a while since I last looked).

That being said, all of these settings can be overwritten by group policy, so, a network administrator may have chosen to lock down the machine.

In any way, unless this is enforced/made so that you can not overwrite it, it is pretty trivial to change.

-edited this section -

The default domain profile does block ping by default...

Click on the Start Orb and type "Windows Firewall" (or as much as needed) and then when it comes up in the results, click on Windows Firewall with Advanced Security. From here, click on Inbound Rules and look for File and Printer Sharing (Echo Request - ICMPv4-In) and simply enable it...

... but, it should be enabled already for the private and public profiles... Look for the one above it that says "Domain" in the profile column and simply click enable in the action bar on the right.

share|improve this answer
    
Checked and there are two rules, one for "Private,Public", the other for "Domain". Both are set "Enabled = No" The only difference I can see is the Domain has "Remote Address = Any", whereas the Private,Public is set to "Local subnet". Tried changing the domain virtual to "Yes", and pinging it, but still get the "Request timed out". –  SteveC Apr 1 '12 at 12:50
    
If enabled = no, this means disabled... Can you enable them? :/ –  William Hilsum Apr 1 '12 at 15:14
    
DOH ... I'd tried enabling the domain one, which didn't work. But when I enabled the Private,Public one, I've got PING :-) Many thanks for the help, now onto the next question ... why can't I access the administrative c$ share on the virtual ? ... getting error code 0x80070035 –  SteveC Apr 3 '12 at 9:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.