Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Linux:

After connecting to the college wifi, going to the network login page logging in, the internet works perfectly as it should.

In Windows:

After connecting to the college wifi, going to the network login page, logging in, Windows shows "Internet access" and the wireless icon turns white. But still after that, regardless of the browser being used, attempting to accessing any page just shows "Sending request". It does work though after a lot of tries, but only in intervals.

But when running Ubuntu 11.10 in VirtualBox, it works properly just like booting in Ubuntu, even if it isn't working on Windows.

The college wifi service is really crappy and has been unable to solve this problem. I'm pretty sure there should be a solution for this, but what? What is it that Ubuntu is doing right and Windows isn't?

Windows settings set to "Automatically detect settings" and no proxy server used.

tracert in Windows shows(when not working)

 Unable to resolve target system name

tracert in Windows shows(when working):

 Tracing route to []
 over a maximum of 30 hops:

 1     *        *        *     Request timed out.
 2     1 ms     1 ms     4 ms
 3     2 ms     1 ms     1 ms []
 4    13 ms    12 ms    12 ms []
 5    37 ms    36 ms    34 ms
 6    33 ms    34 ms    34 ms
 7    33 ms    48 ms    60 ms
 8    39 ms    39 ms    39 ms
 9    39 ms    40 ms    50 ms
10    41 ms    39 ms    40 ms []

Trace complete.

traceroute in Ubuntu:

  traceroute to (, 30 hops max, 60 byte packets
  1  * * *
  2  * * *
  3  * * *
  4  * * *
  5  * * *
  6  * * *
  7  * * *
  8  * * *
  9  * * *
 10  * * *
 11  * * *
 12  * * *
 13  * * *
 14  * * *
 15  * * *
 16  * * *
 17  * * *
 18  * * *
 19  * * *
 20  * * *
 21  * * *
 22  * * *
 23  * * *
 24  * * *
 25  * * *
 26  * * *
 27  * * *
 28  * * *
 29  * * *
 30  * * *

the output of traceroute is varying, sometimes there's some server name on the last line.

enter image description here enter image description here

share|improve this question
Which browsers are you using? Some browsers don't like unintended (at least from their point of view) redirection. – Baarn Mar 31 '12 at 14:55
I have used many browsers on both platforms - Firefox, Chrome, Chromium, Opera, IE7/8/9, Rekonq, Konqueror. And for every broswer in Windows, the exact same problem. No problem for any browser in Linux. No problem even in Ubuntu running from a Live CD. I am pretty sure the wifi service differentiates based on OS, so what I'm asking for is, is there a method by which I can fake a Windows session as a Linux session, so the internet will run fine? – Max Mar 31 '12 at 17:51
Have you talked to the IT support people in charge of the network? – Harry Johnston Apr 2 '12 at 0:16
Even if I did, that would be useless, horrible customer service. (its a paid network) – Max Apr 3 '12 at 7:47
What does echo $http_proxy output under ubuntu? – matthias krull Apr 14 '12 at 13:57
up vote 8 down vote accepted

This kind of redirect is usually from the network forcing all users through their proxy servers. It's possible you don't have proxy auto discovery working properly on Windows, see WPAD on Wikipedia. I've had issues with Firefox and WPAD before, finding the correct proxy address and manually setting it worked. Perhaps you can ask your college's IT department for that information (the proxy address)?

Also, make sure this is checked:

Click for full size

(Especially if using Internet Explorer, though it also effects other programs that use Windows' proxy settings. Firefox is not affected by this.)

Your Ubuntu traceroute shows a whole lot of timing out.. your 'not working' Windows traceroute shows it could not access the DNS server.

Check your DNS server in Ubuntu (cat /etc/resolv.conf)

Check your Windows one (ipconfig /all)

Are they the same? If not, does it help to make them the same? To set the DNS server(s) in Windows:

  1. Type network connections in the start menu search. Go to View Network Connections.

  2. Right click the appropriate adaptor, select Properties

  3. Select TCP/IP (probably IPv4), click Properties

Click for full size

share|improve this answer
I have tried as many browsers as possible on both platforms, and the problem is exactly the same. So I highly doubt that its because of the browser. Also, I ran XP using VirtualBox in Kubuntu, and in that the internet worked perfectly fine, as in Linux. What I'm basically looking for is, is there a method by which I can fake a Windows session as a Linux session, so the internet will work perfect as it runs in Linux? – Max Mar 31 '12 at 17:45
As far as I know, there are no routers that differentiate based on OS. The fact that you can access the login page by navigating directly to the IP probably means either you did not set a proxy correctly (which Linux may have automatically set system wide) or you don't have a DNS server configured properly - try navigating to other sites by IP. The only real difference between Linux and Windows is how their WLAN autoconfiguration works, and since you can navigate directly to the login IP, you are getting onto the network just fine (security settings correct, etc). – Bob Apr 1 '12 at 3:22
The network might be playing games with DNS. Linux doesn't cache DNS requests locally, which would explain why it works. Try running "ipconfig /flushdns" from the command line on your Windows machine and see if the behaviour changes. – Harry Johnston Apr 3 '12 at 22:43
Thanks will try. – Max Apr 4 '12 at 14:30
I have updated this question now, please check it out. – Max Apr 14 '12 at 15:54

Have you tried disabling IPv6 in connection properties? I see you have several link-local IPv6 addresses listed as your default gateway and this is a known bug of Internet Connection Sharing. If you disable IPv6, everything should work.

share|improve this answer
How to do that? – Max Apr 15 '12 at 10:11
See @Bob's screen caps. The option is just above Internet Protocol Version 4. – Apr 15 '12 at 10:12
How to disable it? Sorry didn't quite get it. – Max Apr 15 '12 at 10:16
By un-ticking the box that comes before it? – Apr 15 '12 at 10:21
Oh. -.- The internet has been working consistently on Windows for an hour now, I'm not sure how. I'll try this for a couple of days then inform. Thank you Bob and for your help! – Max Apr 15 '12 at 10:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .