Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set up an account of Windows 8 for my girl friend only to come to the shocking conclusion that it thinks its from Japan (or well somewhere strange):

enter image description here

I noticed she had filled in Swaziland as her location on her Windows Live profile, but I don't recall them speaking Japanese there.

Meanwhile my account seems unaffected and even a local (non-Live) account seemed affected. So far I couldn't find the right setting that would let me change the language of the UI itself.

Any suggestions?

share|improve this question
    
more wierdly, it looks like japanese rather than chinese. –  Journeyman Geek Apr 1 '12 at 14:50
1  
I've got the same problem. Everything is set to Belgium/Dutch but some programs show German words. –  ZippyV Apr 1 '12 at 16:08
8  
Easy solution, go learn Japanese. –  William Hilsum Apr 1 '12 at 17:27

1 Answer 1

up vote 7 down vote accepted

If my comment of learning Japanese doesn't work, do the following:

(may be an easier way, just haven't learnt it yet!)

Open up an Explorer window, and click on Computer

enter image description here

Once in Control panel, click on Language

enter image description here

From here, make sure your language is added, if it isn't add it.

enter image description here

Next, move your language to the top of the list and that should be enough to make it the system default. If it doesn't, click the Advanced settings button on the left.

enter image description here

From here you should be able to install additional languages. Put in the Windows disk and browse to the Langpacks folder on that disk.

(Giving all these pictures as if you are not using your language, the visual clues may help!)

share|improve this answer
    
Actually its only Metro related stuff that's affected, most of the other UI elements, like Settings were still in English. But these steps indeed did the trick, that'll teach me not to do a clean install! –  Ivo Flipse Apr 1 '12 at 18:03
    
I just wonder how it picked the other language in the first place :/ ... it may just be a bug... after all, it is still beta. –  William Hilsum Apr 1 '12 at 18:05
    
I reckon it didn't like an existing non-English language pack (can't recall picking one) and defaulting to supported non-English language packs –  Ivo Flipse Apr 1 '12 at 18:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.