Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This one is strange. I can't seem to get suspend working more than once per power cycle. When I say "power cycle," I mean the only way to get one proper suspend is to cut power from the power supply and boot back up cold. After the proper suspend, I get a failed suspend, and after all reboots or cold boots until power is cut, suspends fail.

I'm using an Asus P8Z68-V PRO GEN3 Pro with a Sandy Bridge Core i7, running on Ubuntu Precise repositories and UEFI. I'm running Nouveau from repository (And Gallium3d compiled from Git, but that does not come into this since I can avoid OpenGL and it still happens the same way) with a GTX 285 (nv50.) I had to build a custom kernel (3.3) in order for ACPI 5.0 to be supported and make suspend work at all. I compiled it using the latest Ubuntu kernel's config file with the additional entries set to the default options. All packages are up to date. I know these are relatively exotic settings, but I'm hoping maybe I can get some help anyways.

The behavior when suspend fails is strange. Upon a proper suspend, all fans turn off and the only led left on, the power led, is blinking. Upon a failed suspend, 1. USB power remains. 2. The power led stays on solid. 3. All fans seem to still be on. 4. I can hear what I believe is the primary hard drive shutting off. 5. Despite USB power remaining, the USB powered keyboard does not respond to anything, and the indicator leds on it shut off. Pressing the power button does nothing, and of course I have not to date found a way to wake it up.

When trouble shooting the first round of issues I got with suspend not too long ago, I ended up building a list of modules to disable upon sleeping. Here's my config file for them:

In /etc/pm/config.d/01modules:

    SUSPEND_MODULES="uhci_hd ehci_hd button"

All of my other pm configuration files are stock. In case it's any help, here are my relevant BIOS settings.

share|improve this question

1 Answer 1

I think it's a bug in Precise. I was having the same problem, but it seems to have gone away after some updates that I ran this morning.

System logs were suggesting that it was something about a repeating hotplug cycle with my USB mouse, so if it happens again, I'm going to try just unplugging the mouse and keyboard to see if that lets it get into suspend mode.

share|improve this answer
    
You could be right. It would appear I'm having the same issue with Fedora as well. Worse, an irreversible BIOS update (ridiculous, I know) has broken my reset button and restart/shutdown functionality (although holding the shutdown button still works.) Regardless of what happens next, I'm going to be more careful with my motherboard choice next time around. –  John Chadwick May 1 '12 at 23:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.