Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my Mac OS X 10.5.8, I changed the color background of the Xterm (X11) by adding the following lines to the file .Xdefaults:

xterm*Background:               black
xterm*Foreground:               green
xterm*cursorColor:              LightBlue
xterm*pointerShape:             arrow
xterm*pointerColor:             blue

It was working well. I did not save other modifications to other files. I switched off the Mac.

The day after, the Xterm just does not open. I click on the icon X11. The bar on the top of the screen shows it is going to open but after a few seconds, it turns back to the previous program and does not open X11. Same result if I try to open it from Applications/Utilities/X11.app it just does not open, but NO error messages or other issues to the other programs open.

I tried to check Finder, Go to Folder, /private/etc/paths.d. It shows /usr/X11/bin. This should be correct. So I do not know how to find the error.

share|improve this question
1  
Have you tried deleting the file .Xdefaults? –  Daniel Beck Apr 1 '12 at 20:02
    
Does Console.app report anything unusual? –  lyricsboy Apr 1 '12 at 20:06
    
Hello thanks for youre replies. Unfortunately still does not work: –  Fred Apr 1 '12 at 20:25
    
I deleted the .Xdefaults and the result does not change. HTere is something unual in the Consol.app, but I have no idea how to use it . –  Fred Apr 1 '12 at 20:30
    
If X11 is starting up and then dying, /var/log/system.log should contain some indication as to why. –  Kyle Jones Apr 1 '12 at 22:10
show 6 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.