Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried everything I could to get the sound working. I've tried to install the drivers from the Snow Leopard disk, then I went and got the latest RealTek drivers from the RealTek website. Then I read that old Mac mini's could have an integrated Cirrus chip, and I tried to grab the latest driver from the website, and it appeared to install, but nothing.

There's also nothing listed under Sound and ... in the Device Manager. I've tried to manually include a legacy driver, which worked for RealTek but not for the Cirrus driver. Of course it said there was no RealTek hardware install, which makes me think it's a Cirrus chip.

Any further suggestions or thoughts would be really appreciated.

This is a Mac Mini 1.66. I'm also not sure how to be able to detect what card is integrated into the system, so that would be helpful too (remembering that there's no driver installed). Even just to get the chip type would be great to confirm.

share|improve this question
what is the model number on the bottom? it should start with MA... – nc4pk Apr 4 '12 at 20:01
Did you run Windows Update? That might update the drivers properly. – harrymc Apr 5 '12 at 10:30
@tapped-out The closest I could find was m40a. However looking up the serial, here's the specs page: – Steph Apr 5 '12 at 16:22
Windows is fully updated. – Steph Apr 5 '12 at 16:23
Is it working on OS X or at startup? – user127350 Apr 11 '12 at 17:34

Try updating the sound drivers to the latest Realtek drivers.

I had to use the second link to get the realtek site to actually work.

share|improve this answer
up vote 1 down vote accepted

The only solution I was able to make work was getting a USB audio card. Specifically I got the Creative Blaster x-fi Pro

share|improve this answer
This doesn't really answer OP's question. – danielcg Feb 9 '13 at 16:13
This comment is by the OP. – Wk_of_Angmar Feb 9 '13 at 19:39
An answer pointing to a commercial product isn't an answer. – leye0 Feb 20 '14 at 20:34

To identify the device - find out its PCI Vendor and Product IDs, then google up the combination.

share|improve this answer

See if you followed the steps the same as they are shown in the manual for your OS.

Snow Leopard (10.6): Lion (10.7):

If you have Mountain Lion, the steps are the same as on Lion so use that manual. There is no manual for Mountain Lion.

share|improve this answer

Belated answer, just had the same problem but got it to work; it's a SigmaTel chip.

The drivers are available in the Bootcamp 4.0.4131 package from Apple here.

share|improve this answer

Had the same problem with my 2006 Mac Mini. Confirmed that PCI Vendor and Product IDs are in fact SigmaTel (under Hardware Ids in the device details tab). Got Boot Camp 4.0.4131 support software and found the IDT SigmaTel driver installer. After reboot, audio worked. I've been so many years without audio in Windows and am so happy to finally have it working. Thanks to all who contributed answers.

share|improve this answer

I have the mac mini 1.1 with this configuration. Intel Core Duo @ 1.73 GHz. 2 GB RAM, and 120 GB HDD. running Mac Os Snowleopard 10.6.8. when I installed Windows via Bootcamp, I found that Windows didnt recognize my real audio device and because of that I got no sound even when it says that the audio codecs are installed and working properly. so the best way to find out what is audio device was, is running an id device software. I used Everest and it found that de audio device was a Sigmatel Audio Devices specifically SigmaTel STAC9220 A1. so I google up for the drivers and boilaa! it worked! I hope this may be helpful to someone else! ;)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .