Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

my centos environment has just become bash shell prompt:

-bash-3.2#

how do I change it back to the usual # prompt? what places should I check for possibly modifications?

Update: I was not clear in my question: the prompt used to be just a single # and supports more syntax(a different shell script than bash 3.2 perhaps)? I would like to switch back to that. for example, ll is not longer supported in this bash shell

share|improve this question

migrated from stackoverflow.com Apr 2 '12 at 5:11

This question came from our site for professional and enthusiast programmers.

    
Undo whatever you did that changed it? –  Mat Apr 1 '12 at 11:00

2 Answers 2

You can set your bash prompt in ~/.bashrc or if you want to do it globally in /etc/bash.bashrc

You mention 'the usual # prompt', but I'm assuming it doesn't always just show #. If you do want it to ever just show #, just setting "PS1='#'" in your bashrc would be sufficient. If you want more information on the prompt, I would suggest reading http://wiki.centos.org/TipsAndTricks/CustomizeBash or the more in depth http://tldp.org/HOWTO/Bash-Prompt-HOWTO/ .

share|improve this answer

set the PS1 environment variable, for more details: http://www.cyberciti.biz/tips/howto-linux-unix-bash-shell-setup-prompt.html

After your update: maybe there is an error while you enter terminal and load user scripts? try:

su - yourusername

and see if there is an error than.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.