Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I hate mobile pages when using my iPhone since it is capable of showing most desktop pages quite nicely, so I disable them whenever I can. I used to have it disabled on Wikipedia as well, and I always got the desktop version for the past 3 years. However, recently I started getting the mobile page again.

Also the option "Disable mobile page" in the bottom seems to have been replaced with "Desktop view", which does give me the desktop site, but not permanently. Next time I visit the site I get the mobile page again.

Is there a solution for this?

PS. We tested this on a friend's Android phone and he has the same problem.

share|improve this question

closed as off topic by ChrisF, Journeyman Geek, Nifle, ta.speot.is, Sathya Apr 8 '12 at 7:59

Questions on Super User are expected to relate to computer software or computer hardware within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Questions about phones are off-topic for Super User. I could migrate this to either Ask Different or Android Enthusiasts, but am not sure which to choose, since you asked about iPhone but the accepted answer is about Android. If you'd like, I can edit out the iPhone part, migrate it to Android Enthusiasts for you, and then you can re-ask about the iPhone on Ask Different. –  nhinkle Apr 3 '12 at 3:03
    
Since phones' and Desktop OSes are merging, and this is a general question about mobile (not really specific to either iOS or Android or a particular browser), I'm not sure this question is suited to be anywhere at all really. –  Marius Apr 30 at 12:06
add comment

2 Answers

up vote 2 down vote accepted

I've found a detailed solution for Android. Check the link below

Force Desktop Version website for Android

I'm not sure about a direct way where you can force Safari to do so. You can try Atomic Browser which can solve your problem. It has desktop version in settings which you can set as default.

share|improve this answer
    
Thank you for the reply. However, I have an iPhone (I only mentioned Android to illustrate that it is not an iPhone issue), and there is AFAIK no way of changing the User Agent in Safari. –  NobleK Apr 2 '12 at 10:58
    
Hi again. I actually already have Atomic installed and use it when there is no other solution. But I prefere to use Safari because of its integration with other parts of iOS. What is weird here is that it used to work fine on Wikipedia, but not anymore. Anyway, your answer is technically correct so I will accept it, although I was hoping for a more seamless solution. –  NobleK Apr 2 '12 at 12:55
add comment

I see that you've found a solution, but let me list some more options:

There are iPhone browsers that let you set the User Agent, e.g. Atomic Web Browser. Setting the User Agent to desktop browser should give you the desktop versions of the websites.

For jailbroken iPhone you could use UserAgent Faker (available in Cydia) and set Mobile Safari's User Agent to Firefox.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.