Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am setting up a Hyper V 2008 R2 Server on my home network to evaluate it for general virtualization usage at work (software development test lab etc).

I don't have a domain at home so its just a workgrouped network. I've got the server installed and running but the problem is the server name won't resolve. NetBios over tcp/ip is enabled and I can remote desktop to it by IP address.

The Hyper V server is just stripped down Windows Server 2008 so it only has a command line and not much else for management UI. Plus not being much of a networking guy I am mostly fumbling around in the dark.

How can I configure it to register itself such that its name will resolve?

Thanks, Don

share|improve this question
    
For server type questions you might want to ask over at serverfault.com instead of Super User. –  Qwerty Sep 14 '09 at 3:06
add comment

1 Answer

up vote 1 down vote accepted

Hyper-V does not need to be connected to a domain, however to configure network setting in R2 is fairly straigh forward.

  • Log on to Hyper-V
  • At Powershell menu select 8
  • Select the Network Adapter by Index number
  • Configure Settings

As for resolving the name, Windows Server 2008 Core disables everything via the firewall, so I would suggest that you disable the firewall first to ensure that this is not what is causing the problem. You can disable the firewall using:

netsh firewall set opmode disable

And to re-enable:

netsh firewall set opmode enable

Lastly use option 4 to enable all the Remote Management features which means you can manage the complete machine remotely once you have fixed the name resolution, or alternatively using the IP address.

If you are using DHCP you can also try running:

ipconfig /flushdns

And

ipconfig /registerdns

Which may fix the connectivity problem as well, but if not in a domain I am not convinced it will work.

share|improve this answer
    
Thanks @Diago. flush and reigsterdns didn't solve it (I am using DHCP). Turning off the firewall did though so that is the culprit with the name resolution. –  dkackman Sep 14 '09 at 11:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.