Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Excel 2007, I have a cell with

"=if(true,1,0)"

as the contents. If I hit the ENTER key I get an error dialog which says, "The formula you typed contains an error."

The flyover help for that cell is shown as

"IF(logical_testc [value_if_true]c [value_if_false])"

. I've checked the language setting for Windows and my separator is still a comma. I also checked on the auto-correction setting of Excel which was blank for ','; I even set ',' to be replaced with ',' to no avail.

If I enter the formula as

"=if(truec 1 c 0 )"

I get the same error dialog. BUT if I try

"=if(true c 1 c 0 )"

it works but when I edit the cell it gets changed back to

"=IF(TRUEc 1c 0 )"

So, why does Excel now think that arguments for formula need to be separated with 'c' instead of ','?

If it matters, this install was an upgrade from Office 2003 but I didn't notice this bug after the upgrade over two years ago.

[Note: I found this issue with a large formula involving Match() and Index() but it shows up with any formula so I've used a simple example above]

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

According to this article Excel uses the List separator defined in the Windows localization settings.

To change it, open the Region and Language control panel and click Additional settings....
enter image description here

Now change the List separator back to , and it should be fixed. enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.