Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since Sunday (April 1st), red and blue are sometimes swapped when I watch videos on YouTube.

Examples are "Peeling Apple Like A Boss" (blue arms and apple) or, to my dismay, the famous Red vs. Blue series (like this video) which sucks.

Here is a screenshot of the RvB episode at 1:28.

Vimeo is OK, other web video services are OK, only most YouTube videos are affected ... well, all that I could find so far.

This video looks OK in Firefox but it's broken in Chrome. The episode of RvB looks wrong in both browsers. Local videos look file.

What could be causing this?

[EDIT] Versions:

openSUSE 12.1
NVIDIA 295.33
Firefox 11.0
Chromium 17.0.922.0
Flash 11.0.1.152

share|improve this question
4  
Sounds like a clever prank on Red vs. Blue fans. :) –  jcrawfordor Apr 2 '12 at 20:29
1  
can you provide us with actual screenshots? –  JohannesM Apr 2 '12 at 20:55
1  
Which operating system? Which version of Google Chrome? –  iglvzx Apr 2 '12 at 21:21
    
@jcrawfordor: Yeah, thought the same ;-) –  Aaron Digulla Apr 3 '12 at 10:14
add comment

4 Answers

up vote 13 down vote accepted

This could have to do with hardware acceleration.

If you are using Flash:

  1. Right click on the video, go to Settings and in the first tab toggle the acceleration checkmark.

  2. Go to http://www.youtube.com/testtube and enable HTML5.

If you are using HTML5:

  1. Go to http://www.youtube.com/testtube and disable HTML5.

  2. Right click on the Flash video, go to Settings and in the first tab toggle the acceleration checkmark.

share|improve this answer
    
Does the acceleration checkmark have an effect immediately or do I have to close the dialog or restart the browser? –  Aaron Digulla Apr 3 '12 at 10:11
    
@AaronDigulla: I think refresh the page, but you could try restarting the browser to be sure. –  Tom Wijsman Apr 3 '12 at 10:12
    
Okay, I'll try that tonight. –  Aaron Digulla Apr 3 '12 at 10:15
3  
HWAccel did it for me. HTML5 video also works. –  Aaron Digulla Apr 3 '12 at 19:42
    
clearing HWAccell finally fixed this for me. HTML5 wasn't an option because it wasn't just youtube that was going into Avatar mode –  Mala Apr 23 '12 at 14:06
add comment

Try to disable the new included Flash plugin. It's new and is causing some problems on Linux, not least on amd64 systems.

  1. Go to chrome://plugins
  2. Press "Details"
  3. "Disable" the Flash with type: "PPAPI" (the other should have type: "NPAPI))

and reload the Youtube page and see if it differs. If so, it is a bug in the new "Pepper Flash" that comes with Chrome and Chromium (on some distributions). If not, activate the internal Flash version again (it is the only one receiving updates on the Linux platform from now on).

(Note: when I click "Disable", the page doesn't react, but if I reload the chrome://plugins page the change is shown.)

share|improve this answer
add comment

I can't disable hardware acceleration, because for some reason, I can't change any settings, but I've found a workaround which works for me: I've downloaded the firefox addon "DownloadHelper", and the colors in the downloaded videos are OK.

You can also try out "YouTube Leanback", which you can find by clicking on "Try something new" on the bottom of the YouTube Page, the colors are alright for me there.

edit: The best workaround is to just watch it on tubereplay.com!

share|improve this answer
    
Downloading every video might not be feasible in some situations. Nice to hear that Lean-back works though. +1 –  Tom Wijsman Apr 3 '12 at 19:36
    
Did you do the mms.conf hack first? Undo that and you can disable it. –  Tom Wijsman Jul 20 '12 at 2:31
    
No, I didn't. I have a new Ubuntu installation now, and now it works, but in the old one, it was just impossible to click on anything in the flashplayer settings pop-up. I could use tab to highlight options, but pressing enter would do nothing. –  Jake Aug 11 '12 at 21:22
    
Yeah, that's an other bug in Flash; what a shame you got both. :( –  Tom Wijsman Aug 11 '12 at 22:19
    
Well, at least everything works since I've reinstalled my OS :) –  Jake Aug 15 '12 at 15:03
add comment

Try (work for me):

mkdir /etc/adobe
echo -e "EnableLinuxHWVideoDecode=1\nOverrideGPUValidation=true" > /etc/adobe/mms.cfg
share|improve this answer
2  
Don't do this, this makes your flash player unstable! –  Tom Wijsman Jul 20 '12 at 2:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.