Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I seem to have a unique issue. I have a mac book pro which I often have connected to one or 2 additional monitors, and I think this is in part my issue. Cause when Im at home working with only the built in monitor and I go to open something new or existing in photoshop my canvas if you will call it that is no where to be found.

I checked my display settings, its treating it as a one monitor solution. I've tried to in photoshop to bring all my windows to front, Ive tried to cascade and tile my windows, ive tried to reset my work area, and to no avail I can't for the life of me get the canvas to come to my screen so I can work with what ever I intend to work on.

Anyone else have this problem or run into similar? How did you fix it?

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

First things first: Make sure that you haven't triggered the automatic hiding mode for all palettes.
Try pressing the Tab key and see if that doesn't bring them all back.

If that doesn't work, the simplest solution to this problem is to just reset the layout of all palettes to the default settings. To do so, open the "Window" menu, point to "Workspace", and select the "Reset Palette Locations" command.

Note that "Reset Palette Locations" is a very different command than "Default Workspace". Selecting "Default Workspace" will cause Photoshop to reset all palette customizations back to their default settings (not just their positions). This will cause you to lose any custom styles, brush sets, actions, and so on that you may have set up.

If that doesn't work, you can try trashing Photoshop's preference file.

share|improve this answer
add comment

in system preferences -> display choose a smaller resolution for your screen size. This should force all active windows to re-size to that resolution. Then put the resolution back to the original, the windows will stay on your screen.

share|improve this answer
add comment

Try: View --> Screen Mode --> Standard Screen Mode

Sometimes my Photoshop resets itself to Maximized Screen Mode. This sends the image frames off-screen. Doing the above resets the frame edge back to the center of your screen/working area.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.